aboutsummaryrefslogtreecommitdiffstats
path: root/java/eclipse
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2005-06-19 03:08:51 +0800
committernork <nork@FreeBSD.org>2005-06-19 03:08:51 +0800
commitd07f63e421f7a48c07035a167ece3e4b7edbe249 (patch)
treebd76550c4f07de8299e5dbb0e27da5a4084f84b6 /java/eclipse
parent65d8e3312783e546ffc8e8a1418e19dea378fe37 (diff)
downloadfreebsd-ports-gnome-d07f63e421f7a48c07035a167ece3e4b7edbe249.tar.gz
freebsd-ports-gnome-d07f63e421f7a48c07035a167ece3e4b7edbe249.tar.zst
freebsd-ports-gnome-d07f63e421f7a48c07035a167ece3e4b7edbe249.zip
Add support for other mozilla's.
PR: ports/81753 Submitted by: Andreas Kohn <andreas@syndrom23.de>
Diffstat (limited to 'java/eclipse')
-rw-r--r--java/eclipse/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 42c0c9e08425..f2612ba87082 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -48,9 +48,9 @@ PLIST_SUB+= MOTIF:=""
ECLIPSE_WS= gtk
PLIST_SUB+= GTK:=""
PLIST_SUB+= MOTIF:="@comment "
-.if defined(WITH_MOZILLA) && ${WITH_MOZILLA} == "firefox"
-BUILD_DEPENDS+= firefox:${PORTSDIR}/www/firefox
-BROWSER= firefox
+.if defined(WITH_MOZILLA)
+BROWSER= ${WITH_MOZILLA}
+BUILD_DEPENDS+= ${BROWSER}:${PORTSDIR}/www/${BROWSER}
.else
BUILD_DEPENDS+= mozilla:${PORTSDIR}/www/mozilla
BROWSER= mozilla