aboutsummaryrefslogtreecommitdiffstats
path: root/java/jakarta-commons-collections
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-12-01 10:33:56 +0800
committerhq <hq@FreeBSD.org>2004-12-01 10:33:56 +0800
commit3b1b2a953face89001fbd7acda0bd5ce41725dc7 (patch)
tree2605788d0a588d73aa487b9e1ab6c3aeaaa4fb60 /java/jakarta-commons-collections
parentc6a4be77912b7ead0e5251fe87db6f7c69b22288 (diff)
downloadfreebsd-ports-gnome-3b1b2a953face89001fbd7acda0bd5ce41725dc7.tar.gz
freebsd-ports-gnome-3b1b2a953face89001fbd7acda0bd5ce41725dc7.tar.zst
freebsd-ports-gnome-3b1b2a953face89001fbd7acda0bd5ce41725dc7.zip
Link API documentation with JDK API documentation, if installed.
Diffstat (limited to 'java/jakarta-commons-collections')
-rw-r--r--java/jakarta-commons-collections/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/java/jakarta-commons-collections/Makefile b/java/jakarta-commons-collections/Makefile
index 1c95022a90d7..43ea6cc766b1 100644
--- a/java/jakarta-commons-collections/Makefile
+++ b/java/jakarta-commons-collections/Makefile
@@ -32,6 +32,13 @@ JARFILE= ${PORTNAME}-${PORTVERSION}.jar
DESTJARFILE= ${PORTNAME}.jar
PLIST_FILES+= %%JAVAJARDIR%%/${DESTJARFILE}
+.include <bsd.port.pre.mk>
+
+JDK_API!= (${FIND} -s ${LOCALBASE}/share/doc/jdk1.? -maxdepth 1 -name api -type d 2>/dev/null || ${TRUE}) | ${TAIL} -n 1
+.if ${JDK_API} != ""
+MAKE_ARGS+= -Djavadoc.links=${JDK_API}
+.endif
+
do-install:
@${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${DESTJARFILE}..."
@${MKDIR} ${JAVAJARDIR}
@@ -47,4 +54,4 @@ do-install:
@${ECHO_MSG} " [ DONE ]"
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>