aboutsummaryrefslogtreecommitdiffstats
path: root/java/jboss4/Makefile
diff options
context:
space:
mode:
authorznerd <znerd@FreeBSD.org>2003-07-11 15:14:31 +0800
committerznerd <znerd@FreeBSD.org>2003-07-11 15:14:31 +0800
commite75407b3dadbb0061df4e9d8d22f71d11c632f8a (patch)
treedf2a38718b8df7b3fd8ca967d0736882cb0e654b /java/jboss4/Makefile
parent8bd20667ed5d78be016609f3edeef9ad8fe3bd9e (diff)
downloadfreebsd-ports-gnome-e75407b3dadbb0061df4e9d8d22f71d11c632f8a.tar.gz
freebsd-ports-gnome-e75407b3dadbb0061df4e9d8d22f71d11c632f8a.tar.zst
freebsd-ports-gnome-e75407b3dadbb0061df4e9d8d22f71d11c632f8a.zip
Patch to delete the symbol CR (carriage return) in some files.
Bumped PORTREVISION. Submitted by: Ivanchenko V. I. <webmaster@asiamusic.ru>
Diffstat (limited to 'java/jboss4/Makefile')
-rw-r--r--java/jboss4/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/java/jboss4/Makefile b/java/jboss4/Makefile
index 0de2ee499485..ea9000c03f49 100644
--- a/java/jboss4/Makefile
+++ b/java/jboss4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ${APP_TITLE:L}
PORTVERSION= 3.0.7
+PORTREVISION= 1
CATEGORIES= java
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -49,8 +50,19 @@ WRKDIR?= ${WRKDIRPREFIX}${.CURDIR}/work
.include <bsd.port.pre.mk>
post-patch:
- @${ECHO_CMD} -n ">> Removing unneeded files..."
- @${RM} -f `${FIND} ${WRKSRC} -name '*.bat'` `${FIND} ${WRKSRC} -name '*.orig'` `${FIND} ${WRKSRC} -name '*.exe'`
+ @${ECHO_CMD} -n ">> Deleting the symbol CR (carriage return) in some files and removing unneeded files..."
+ @${FIND} ${WRKSRC} -type f \
+ -iname '*.mf' -or \
+ -iname '*.dtd' -or \
+ -iname '*.txt' -or \
+ -iname '*.xml' -or \
+ -iname '*.conf' -or \
+ -iname '*.java' -or \
+ -iname '*.html' -or \
+ -iname '*.policy' -or \
+ -iname '*.properties' | \
+ ${XARGS} -n 10 -x ${SED} -i .orig -e "s|"`printf '\015'`"||g"
+ @cd ${WRKSRC} && ${FIND} . -type f -name "*.orig" -print -or -iname "*.bat" -print -or -iname "*.exe" -print | ${XARGS} ${RM} -f
@${ECHO_CMD} " [ DONE ]"
@${CHMOD} -R 0644 ${WRKSRC}
@${CHMOD} 0755 `${FIND} ${WRKSRC} -type d`