aboutsummaryrefslogtreecommitdiffstats
path: root/java/jcalendar
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-04-07 16:37:29 +0800
committerijliao <ijliao@FreeBSD.org>2004-04-07 16:37:29 +0800
commit797693fd94e4d19402ae80848707f12e45a47b72 (patch)
tree85f14f9d7da56fba39b150240ac199d63ca10db9 /java/jcalendar
parenta024d3aff7c12855079c30c53277e7467943aea9 (diff)
downloadfreebsd-ports-gnome-797693fd94e4d19402ae80848707f12e45a47b72.tar.gz
freebsd-ports-gnome-797693fd94e4d19402ae80848707f12e45a47b72.tar.zst
freebsd-ports-gnome-797693fd94e4d19402ae80848707f12e45a47b72.zip
add jcalendar 1.1.4
Java Date Chooser
Diffstat (limited to 'java/jcalendar')
-rw-r--r--java/jcalendar/Makefile38
-rw-r--r--java/jcalendar/distinfo2
-rw-r--r--java/jcalendar/pkg-descr7
3 files changed, 47 insertions, 0 deletions
diff --git a/java/jcalendar/Makefile b/java/jcalendar/Makefile
new file mode 100644
index 000000000000..cd976c1855f9
--- /dev/null
+++ b/java/jcalendar/Makefile
@@ -0,0 +1,38 @@
+# ex:ts=8
+# Ports collection makefile for: jcalendar
+# Date created: Apr 2, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= jcalendar
+PORTVERSION= 1.1.4
+CATEGORIES= java
+MASTER_SITES= http://www.toedter.com/download/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Java Date Chooser
+
+USE_ZIP= yes
+USE_JAVA= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+PLIST_FILES= ${JAVAJARDIR:S,^${PREFIX}/,,}/jcalendar.jar \
+ ${JAVAJARDIR:S,^${PREFIX}/,,}/kunststoff.jar
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+do-install:
+.for file in jcalendar.jar kunststoff.jar
+ ${INSTALL_DATA} ${WRKSRC}/lib/${file} ${JAVAJARDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/docs/ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/java/jcalendar/distinfo b/java/jcalendar/distinfo
new file mode 100644
index 000000000000..3925c2eac02f
--- /dev/null
+++ b/java/jcalendar/distinfo
@@ -0,0 +1,2 @@
+MD5 (jcalendar.zip) = 9e5b1b9e270b52cc3ca1f3870ce28a14
+SIZE (jcalendar.zip) = 243739
diff --git a/java/jcalendar/pkg-descr b/java/jcalendar/pkg-descr
new file mode 100644
index 000000000000..8b6ee2edce05
--- /dev/null
+++ b/java/jcalendar/pkg-descr
@@ -0,0 +1,7 @@
+JCalendar is a Java date chooser bean for graphically picking a date. JCalendar
+is composed of several other Java beans, a JDayChooser, a JMonthChooser and a
+JYearChooser. All these beans have a locale property, provide several icons
+(Color 16x16, Color 32x32, Mono 16x16 and Mono 32x32) and their own locale
+property editor. So they can easily be used in GUI builders.
+
+WWW: http://www.toedter.com/en/jcalendar/