aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk12
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2003-06-15 13:53:02 +0800
committerglewis <glewis@FreeBSD.org>2003-06-15 13:53:02 +0800
commit41f5865da7558f738d555375d1eaa23cda9ec5cd (patch)
tree676fa407071572b4df14e5a87fcd2f04378ac8e7 /java/jdk12
parent9758461d4cfd5811dee1a40b351c8a51a5f699ed (diff)
downloadfreebsd-ports-gnome-41f5865da7558f738d555375d1eaa23cda9ec5cd.tar.gz
freebsd-ports-gnome-41f5865da7558f738d555375d1eaa23cda9ec5cd.tar.zst
freebsd-ports-gnome-41f5865da7558f738d555375d1eaa23cda9ec5cd.zip
. Reorder the check for the source and patchset so that the failure
messages are produced in the order that they were intended.
Diffstat (limited to 'java/jdk12')
-rw-r--r--java/jdk12/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/java/jdk12/Makefile b/java/jdk12/Makefile
index a11dc38e3d5a..5def629433c3 100644
--- a/java/jdk12/Makefile
+++ b/java/jdk12/Makefile
@@ -76,6 +76,17 @@ PLIST_SUB+= DEBUG:=""
.include <bsd.port.pre.mk>
+# Check for patchset
+.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= :\n\
+The source distribution exists on your system, but due to\n\
+licensing restrictions you still need to download the\n\
+patchset, ${PATCHSETFILE}, from\n\
+http://www.eyesbeyond.com/freebsddom/java/jdk.html.\n\
+Please place the patchset in ${DISTDIR}.\n
+.endif
+
# Check for JDK sources
.if !exists(${DISTDIR}/${SRCFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
@@ -90,17 +101,6 @@ download the file \"${SRCFILE}\". Please place this file in\n\
${DISTDIR}.\n
.endif
-# Check for patchset
-.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
-The source distribution exists on your system, but due to\n\
-licensing restrictions you still need to download the\n\
-patchset, ${PATCHSETFILE}, from\n\
-http://www.eyesbeyond.com/freebsddom/java/jdk.html.\n\
-Please place the patchset in ${DISTDIR}.\n
-.endif
-
pre-patch:
@${MKDIR} ${WRKSRC}
.for dir in build src ext/i18n/build ext/i18n/src ext/iiimp/build