aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk13-doc
diff options
context:
space:
mode:
authordougb <dougb@FreeBSD.org>2001-05-31 17:19:23 +0800
committerdougb <dougb@FreeBSD.org>2001-05-31 17:19:23 +0800
commite59fb0052f8e06fee62d1e082dbafeb9ccc2fcf1 (patch)
tree1b6c35f14bf2da7e800ab0466807d0179edfb3a1 /java/jdk13-doc
parentcebba578027eeaa49f5ebb86ff066587a271ebea (diff)
downloadfreebsd-ports-gnome-e59fb0052f8e06fee62d1e082dbafeb9ccc2fcf1.tar.gz
freebsd-ports-gnome-e59fb0052f8e06fee62d1e082dbafeb9ccc2fcf1.tar.zst
freebsd-ports-gnome-e59fb0052f8e06fee62d1e082dbafeb9ccc2fcf1.zip
My modification of the submitter's update didn't go far enough,
thereby causing breakage that was not present in the original. Fix the test for distfile a different way, using fewer variables and less gymnastics.
Diffstat (limited to 'java/jdk13-doc')
-rw-r--r--java/jdk13-doc/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/java/jdk13-doc/Makefile b/java/jdk13-doc/Makefile
index f18463c022ee..ec8a09c78a12 100644
--- a/java/jdk13-doc/Makefile
+++ b/java/jdk13-doc/Makefile
@@ -17,7 +17,7 @@ NO_CDROM= "License does not allow distribution with fee."
RESTRICTED= "This software is under license and export control."
.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute packages"
+IGNORE= "You cannot legally distribute packages"
.endif
PLIST_SUB+= JDK_HOME=${JDK_HOME:S/^${PREFIX}\///}
@@ -29,11 +29,9 @@ NO_BUILD= yes
.include <bsd.port.pre.mk>
-.for file in ${DISTFILES}
-.if !exists(${DISTDIR}/${file})
-IGNORE=You must manually fetch ${file} from http://java.sun.com/jdk/1.1/docs.html, place it in ${DISTDIR} and then run make again.
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE=You must manually fetch ${DISTNAME}${EXTRACT_SUFX} from http://java.sun.com/jdk/1.1/docs.html, place it in ${DISTDIR} and then run make again
.endif
-.endfor
do-install:
${MKDIR} ${PREFIX}/jdk${PORTVERSION}