aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk13/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-07-08 05:38:45 +0800
committerglewis <glewis@FreeBSD.org>2002-07-08 05:38:45 +0800
commitb7366b21ec11a3a6fe9819b073f989e8f3387dd7 (patch)
treeabd1e65bb5581359adcd6e02c3c660551f9346fe /java/jdk13/Makefile
parent9c390d6350d74f97ae50442c1dae82f9308a9785 (diff)
downloadfreebsd-ports-gnome-b7366b21ec11a3a6fe9819b073f989e8f3387dd7.tar.gz
freebsd-ports-gnome-b7366b21ec11a3a6fe9819b073f989e8f3387dd7.tar.zst
freebsd-ports-gnome-b7366b21ec11a3a6fe9819b073f989e8f3387dd7.zip
Only depend on the Linux JDK when NATIVE_BOOTSTRAP isn't defined.
Diffstat (limited to 'java/jdk13/Makefile')
-rw-r--r--java/jdk13/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index aca08da79be3..a6c683ac8c20 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -19,8 +19,10 @@ MAINTAINER= glewis@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
zip:${PORTSDIR}/archivers/zip \
gtar:${PORTSDIR}/archivers/gtar \
- ${JDK13DIR}/bin/javac:${PORTSDIR}/java/linux-sun-jdk13 \
${X11BASE}/lib/libMrm.a:${PORTSDIR}/x11-toolkits/open-motif
+.if !defined(NATIVE_BOOTSTRAP)
+BUILD_DEPENDS+= ${JDK13DIR}/bin/javac:${PORTSDIR}/java/linux-sun-jdk13
+.endif
.if !defined(WITHOUT_PLUGIN)
BUILD_DEPENDS+= msgfmt:${PORTSDIR}/devel/gettext
LIB_DEPENDS= glib12.3:$(PORTSDIR)/devel/glib12 \
ons'>+1 * Fix build without texinfo in basebapt2014-06-251-1/+1 * Fix building zsh on a FreeBSD which is a NIS client [1]bapt2014-06-231-1/+3 * Package somethingantoine2014-06-222-0/+4 * Correct typo... it's tar:bzip2, not tar:bz2.adamw2014-06-204-4/+4 * Use the @shell helper instead of custom pkg-install/deinstall scripts.adamw2014-06-203-45/+0 * Use the USES=tar:... variants.adamw2014-06-208-15/+11 * USES, and remove unnecessary +='s from OPTIONS helpers.adamw2014-06-201-4/+4 * NOPORTEXAMPLES :(adamw2014-06-201-3/+2 * No need to include bsd.options.mk here. While here, sort plist.adamw2014-06-202-5/+1 * Test ICONV_LIB instead of being dependant on an OSVERSIONbapt2014-06-181-5/+3 * Only pickup iconv from base even if libiconv is installed [1]bapt2014-06-161-1/+6 * - Update MASTER_SITESsunpoet2014-06-131-1/+1 * Reset the 99 ports still listed under sylvio@marino2014-06-122-2/+2 * Add an @shell keyword to handle adding and remove a shell path in /etc/shellbapt2014-06-1224-69/+28 * Use @samplebapt2014-06-121-3/+1 * Remove all space characters from Makefile assignments.olgeni2014-06-091-1/+1 * - Update to 20140410miwi2014-06-033-5/+5 * This port are no longer used or cared for.nemysis2014-05-291-1/+1 * - Update to 4.3.18ehaupt2014-05-272-2/+15 * shells/dash: add note, change maintainereadler2014-05-271-1/+2 * Update to 3.01b.knu2014-05-23