aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk13
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2003-06-15 13:53:02 +0800
committerglewis <glewis@FreeBSD.org>2003-06-15 13:53:02 +0800
commit41f5865da7558f738d555375d1eaa23cda9ec5cd (patch)
tree676fa407071572b4df14e5a87fcd2f04378ac8e7 /java/jdk13
parent9758461d4cfd5811dee1a40b351c8a51a5f699ed (diff)
downloadfreebsd-ports-gnome-41f5865da7558f738d555375d1eaa23cda9ec5cd.tar.gz
freebsd-ports-gnome-41f5865da7558f738d555375d1eaa23cda9ec5cd.tar.zst
freebsd-ports-gnome-41f5865da7558f738d555375d1eaa23cda9ec5cd.zip
. Reorder the check for the source and patchset so that the failure
messages are produced in the order that they were intended.
Diffstat (limited to 'java/jdk13')
-rw-r--r--java/jdk13/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index 9fcfa67d73fe..aaabdfbc7f48 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -132,6 +132,17 @@ BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
TAR= gtar # Necessary for proper extraction of sources
.endif
+# Check for patchset
+.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
+ECHO_MSG=/usr/bin/printf
+IGNORE= :\n\
+The source distribution exists on your system, but due to\n\
+licensing restrictions you still need to download the\n\
+patchset, ${PATCHSETFILE}, from\n\
+http://www.eyesbeyond.com/freebsddom/java/jdk13.html.\n\
+Please place the patchset in ${DISTDIR}.\n
+.endif
+
# Check for JDK sources
.if !exists(${DISTDIR}/${SRCFILE}) && !defined(PACKAGE_BUILDING)
ECHO_MSG=/usr/bin/printf
@@ -146,17 +157,6 @@ download the source file, ${SRCFILE}. Please place this file in\n\
${DISTDIR}.\n
.endif
-# Check for patchset
-.if !exists(${DISTDIR}/${PATCHSETFILE}) && !defined(PACKAGE_BUILDING)
-ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
-The source distribution exists on your system, but due to\n\
-licensing restrictions you still need to download the\n\
-patchset, ${PATCHSETFILE}, from\n\
-http://www.eyesbeyond.com/freebsddom/java/jdk13.html.\n\
-Please place the patchset in ${DISTDIR}.\n
-.endif
-
# HotSpot and/or native threads require a recent version of FreeBSD
.if ( defined(WITH_NATIVE_THREADS) || defined(WITH_HOTSPOT) ) && ( ${OSVERSION} < 470101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500043 ) )
ECHO_MSG=/usr/bin/printf