aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk13
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-08-07 00:36:21 +0800
committerglewis <glewis@FreeBSD.org>2002-08-07 00:36:21 +0800
commit176a1affc54e2637b6e8c825530e22b4f246eaf3 (patch)
tree447950762ef11e1d42bcd2b4511e44c127cc0079 /java/jdk13
parent5b8acfcd659b9ec16eba75712e5ff253b19f93b3 (diff)
downloadfreebsd-ports-gnome-176a1affc54e2637b6e8c825530e22b4f246eaf3.tar.gz
freebsd-ports-gnome-176a1affc54e2637b6e8c825530e22b4f246eaf3.tar.zst
freebsd-ports-gnome-176a1affc54e2637b6e8c825530e22b4f246eaf3.zip
Add a check in pre-build for a sysctl which will cause an error during
bootstrapping with the Linux JDK.
Diffstat (limited to 'java/jdk13')
-rw-r--r--java/jdk13/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/java/jdk13/Makefile b/java/jdk13/Makefile
index c9cf50626a3d..d66e332faf9b 100644
--- a/java/jdk13/Makefile
+++ b/java/jdk13/Makefile
@@ -132,6 +132,15 @@ pre-build:
echo "This is known to cause problems during bootstrapping."; \
exit 1; \
fi
+ @if [ `sysctl -n compat.linux.osname` != "Linux" ]; \
+ then \
+ echo "Please set the value of the sysctl compat.linux.osname"; \
+ echo "to 'Linux' with the command:"; \
+ echo " sysctl compat.linux.osname=Linux"; \
+ echo "Having it set to other values, such as 'FreeBSD',"; \
+ echo "is known to cause problems during bootstrapping."; \
+ exit 1; \
+ fi
.endif
post-build: