aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk14/Makefile
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-11-01 04:20:37 +0800
committerglewis <glewis@FreeBSD.org>2002-11-01 04:20:37 +0800
commitf2327edbdbf51b9fe806e27ebb8c634cd224e49a (patch)
tree4f0344eb6c1bc1bb5a51a5f98e1d0406b6753dad /java/jdk14/Makefile
parente1dc3084be7c61a1bb653a952c7a6c7aaf52509d (diff)
downloadfreebsd-ports-gnome-f2327edbdbf51b9fe806e27ebb8c634cd224e49a.tar.gz
freebsd-ports-gnome-f2327edbdbf51b9fe806e27ebb8c634cd224e49a.tar.zst
freebsd-ports-gnome-f2327edbdbf51b9fe806e27ebb8c634cd224e49a.zip
. Add optional (default: off) runtime dependencies for the font packages
necessary to support the different font.properties that are installed.
Diffstat (limited to 'java/jdk14/Makefile')
-rw-r--r--java/jdk14/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/java/jdk14/Makefile b/java/jdk14/Makefile
index ca17e5eec65e..3e59069ca2e1 100644
--- a/java/jdk14/Makefile
+++ b/java/jdk14/Makefile
@@ -33,6 +33,16 @@ RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
${X11BASE}/lib/libXm.so:${PORTSDIR}/x11-toolkits/open-motif \
${X11BASE}/lib/X11/fonts/URW/fonts.dir:${PORTSDIR}/x11-fonts/urwfonts
+.if defined(WITH_JAPANESE_FONTS)
+RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/TrueType/fonts.dir.kochi:${PORTSDIR}/japanese/kochi-ttfonts
+.endif
+.if defined(WITH_RUSSIAN_FONTS)
+RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/webfonts/fonts.dir:${PORTSDIR}/x11-fonts/webfonts
+.endif
+.if defined(WITH_CHINESE_FONTS)
+RUN_DEPENDS+= ${LOCALBASE}/share/fonts/TrueType/arphic:${PORTSDIR}/chinese/arphicttf
+.endif
+
WRKSRC= ${WRKDIR}/j2sdk1.3.1/make
JDK_VERSION= 1.3.1