aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk15
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-08-06 02:19:58 +0800
committerglewis <glewis@FreeBSD.org>2002-08-06 02:19:58 +0800
commit0a334dfe2bf3d8d6973beab4507857ac2ba72489 (patch)
tree12e38c1d0ab6ecb9448f0afc3e791115227b0f67 /java/jdk15
parentca7da0820f9fee7240323e3ae0da58d65f3c0832 (diff)
downloadfreebsd-ports-gnome-0a334dfe2bf3d8d6973beab4507857ac2ba72489.tar.gz
freebsd-ports-gnome-0a334dfe2bf3d8d6973beab4507857ac2ba72489.tar.zst
freebsd-ports-gnome-0a334dfe2bf3d8d6973beab4507857ac2ba72489.zip
Now that sobomax has updated the system version of tar don't redefine
TAR and add gtar to BUILD_DEPENDS unless the OSVERSION is old enough. Small tweak by me to note that sobomax has MFC'ed the tar update. Submitted by: Mikhail Teterin <mi@aldan.algebra.com>
Diffstat (limited to 'java/jdk15')
-rw-r--r--java/jdk15/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index dbf1c7ba5b51..c9cf50626a3d 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -17,7 +17,6 @@ MAINTAINER= glewis@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
zip:${PORTSDIR}/archivers/zip \
- gtar:${PORTSDIR}/archivers/gtar \
${X11BASE}/lib/libMrm.a:${PORTSDIR}/x11-toolkits/open-motif
.if !defined(NATIVE_BOOTSTRAP)
BUILD_DEPENDS+= ${JDK13DIR}/bin/javac:${PORTSDIR}/java/linux-sun-jdk13
@@ -63,7 +62,6 @@ ALL_TARGET= all plugin images
.else
ALL_TARGET= all images
.endif
-TAR= gtar # Necessary for proper extraction of sources
PLIST_SUB+= JDK_VERSION=${JDK_VERSION}
JDKIMAGEDIR= ${WRKSRC}/../build/bsd-i386/jdk-image-i386
@@ -98,6 +96,11 @@ IGNORE= "You can not legally distribute pre-compiled binaries"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 460101 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500038 )
+BUILD_DEPENDS+= gtar:${PORTSDIR}/archivers/gtar
+TAR= gtar # Necessary for proper extraction of sources
+.endif
+
.for file in ${DISTFILES}
.if !exists(${DISTDIR}/${file})
IGNORE=You must manually fetch the source distribution and FreeBSD patches (${DISTFILES}) from http://www.sun.com/software/java2/download.html and http://www.eyesbeyond.com/freebsddom/java/jdk13.html, place it in ${DISTDIR} and then run make again