aboutsummaryrefslogtreecommitdiffstats
path: root/java/jdk16
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2005-09-04 22:31:32 +0800
committerglewis <glewis@FreeBSD.org>2005-09-04 22:31:32 +0800
commit889f84a231519abfeecc0df32a72f53c73c66f4d (patch)
tree83d63eaaa8f4ad81d6104a324f4307b4c19afe8c /java/jdk16
parented9f034fed52247ada08af8b721dcda186333133 (diff)
downloadfreebsd-ports-gnome-889f84a231519abfeecc0df32a72f53c73c66f4d.tar.gz
freebsd-ports-gnome-889f84a231519abfeecc0df32a72f53c73c66f4d.tar.zst
freebsd-ports-gnome-889f84a231519abfeecc0df32a72f53c73c66f4d.zip
. Generate the class data shared archive during post-install to speed
up VM load times. See http://java.sun.com/j2se/1.5.0/docs/guide/vm/class-data-sharing.html Suggested by: "Ronald Klop" <ronald-freebsd8@klop.yi.org> Approved by: phantom (maintainer)
Diffstat (limited to 'java/jdk16')
-rw-r--r--java/jdk16/Makefile3
-rw-r--r--java/jdk16/files/pkg-install.in26
2 files changed, 18 insertions, 11 deletions
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index 9fecbd340c4f..e9dc343d6490 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -102,7 +102,8 @@ MAKE_ENV+= DONT_ENABLE_IPV6="YES"
ALL_TARGET= all
PLIST_FILES= jdk${JDK_VERSION}/jre/.systemPrefs/.system.lock \
- jdk${JDK_VERSION}/jre/.systemPrefs/.systemRootModFile
+ jdk${JDK_VERSION}/jre/.systemPrefs/.systemRootModFile \
+ jdk${JDK_VERSION}/jre/lib/${ARCH}/client/classes.jsa
PLIST_DIRS= jdk${JDK_VERSION}/jre/.systemPrefs
.if (${ARCH} == amd64)
diff --git a/java/jdk16/files/pkg-install.in b/java/jdk16/files/pkg-install.in
index fa980a9778f0..c85ac26b433d 100644
--- a/java/jdk16/files/pkg-install.in
+++ b/java/jdk16/files/pkg-install.in
@@ -1,19 +1,25 @@
#!/bin/sh
# System preference location
-PREFS_LOCATION=%%JRE_HOME%%
+JRE_HOME=%%JRE_HOME%%
-# Set up system preferences during post install
+# Post-install actions
if [ "$2" = "POST-INSTALL" ]; then
- if [ ! -d "${PREFS_LOCATION}/.systemPrefs" ] ; then
- mkdir -m 755 "${PREFS_LOCATION}/.systemPrefs"
+ # Set up system preferences
+ if [ ! -d "${JRE_HOME}/.systemPrefs" ] ; then
+ mkdir -m 755 "${JRE_HOME}/.systemPrefs"
fi
- if [ ! -f "${PREFS_LOCATION}/.systemPrefs/.system.lock" ] ; then
- touch "${PREFS_LOCATION}/.systemPrefs/.system.lock"
- chmod 644 "${PREFS_LOCATION}/.systemPrefs/.system.lock"
+ if [ ! -f "${JRE_HOME}/.systemPrefs/.system.lock" ] ; then
+ touch "${JRE_HOME}/.systemPrefs/.system.lock"
+ chmod 644 "${JRE_HOME}/.systemPrefs/.system.lock"
fi
- if [ ! -f "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile" ] ; then
- touch "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
- chmod 644 "${PREFS_LOCATION}/.systemPrefs/.systemRootModFile"
+ if [ ! -f "${JRE_HOME}/.systemPrefs/.systemRootModFile" ] ; then
+ touch "${JRE_HOME}/.systemPrefs/.systemRootModFile"
+ chmod 644 "${JRE_HOME}/.systemPrefs/.systemRootModFile"
+ fi
+
+ # Set up class data sharing
+ if [ -x "${JRE_HOME}/bin/java" ]; then
+ "${JRE_HOME}/bin/java" -Xshare:dump
fi
fi