aboutsummaryrefslogtreecommitdiffstats
path: root/java/jgraphx
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-01-19 13:57:33 +0800
committerwen <wen@FreeBSD.org>2010-01-19 13:57:33 +0800
commit4734abe19c1ad1fe333092e0299471cf4d9c6dd4 (patch)
treeef91aae88b11143fa1e55e2000c148dde4fe28c6 /java/jgraphx
parent838b81675778e8eeb567f9233bafc373d29d7fb7 (diff)
downloadfreebsd-ports-gnome-4734abe19c1ad1fe333092e0299471cf4d9c6dd4.tar.gz
freebsd-ports-gnome-4734abe19c1ad1fe333092e0299471cf4d9c6dd4.tar.zst
freebsd-ports-gnome-4734abe19c1ad1fe333092e0299471cf4d9c6dd4.zip
JGraph is the most powerful, lightweight, feature-rich, and thoroughly
documented open-source graph component available for Java. It is accompanied by JGraphpad, the first free diagram editor for Java that offers XML, Drag and Drop and much more! With the JGraph zoomable component, you can display objects and relations (networks) in any Swing UI. JGraph can also be used on the server-side, for example to read a GXL graph, apply a custom layout algorithm, and return the result as a HTML image map. WWW: http://www.jgraph.com/jgraphx.html PR: ports/142541 Submitted by: Chris Rees <utisoft@gmail.com>
Diffstat (limited to 'java/jgraphx')
-rw-r--r--java/jgraphx/Makefile68
-rw-r--r--java/jgraphx/distinfo3
-rw-r--r--java/jgraphx/pkg-descr11
3 files changed, 82 insertions, 0 deletions
diff --git a/java/jgraphx/Makefile b/java/jgraphx/Makefile
new file mode 100644
index 000000000000..fd3288ac8002
--- /dev/null
+++ b/java/jgraphx/Makefile
@@ -0,0 +1,68 @@
+# Ports collection Makefile for: jgraphx
+# Date created: 5 Jan 2010
+# Whom: Chris Rees
+#
+# $FreeBSD$
+#
+
+PORTNAME= jgraphx
+PORTVERSION= 1.2.0.5
+CATEGORIES= java graphics
+MASTER_SITES= http://www.jgraph.com/downloads/jgraphx/archive/ \
+ http://www.bayofrum.net/dist/jgraphx/
+DISTNAME= ${PORTNAME}-${PORTVERSION:C/\./_/g}
+
+MAINTAINER= utisoft@gmail.com
+COMMENT= The Java Graph Diagram Component version X (jgraph v6+)
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_RUN= yes
+
+.if !defined(WITHOUT_COMPILE) || !defined(NOPORTDOCS)
+BUILD_DEPENDS+= ${ANT_CMD}:${PORTSDIR}/devel/apache-ant
+ANT_CMD?= ${LOCALBASE}/bin/ant
+ANT= ${SETENV} JAVA_HOME=${JAVA_HOME} ${ANT_CMD}
+.endif
+
+.if !defined(WITHOUT_COMPILE)
+JAVA_BUILD= yes
+.endif
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITHOUT_COMPILE=yes Install the pre-compiled .jar file"
+ @${ECHO_MSG} ""
+
+do-build:
+.if !defined(WITHOUT_COMPILE) || !defined(NOPORTDOCS)
+ @cd ${WRKSRC} && ${ANT} ${ANT_TARGETS}
+.endif
+
+do-install: do-install-jar do-install-javadoc
+
+do-install-jar:
+ @${ECHO_CMD} -n ">> Installing .jar file..."
+ @${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_CMD} " [DONE]"
+
+do-install-javadoc:
+.if !defined(NOPORTDOCS)
+ @${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${FIND} . \
+ | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+ @${ECHO_CMD} " [DONE]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/java/jgraphx/distinfo b/java/jgraphx/distinfo
new file mode 100644
index 000000000000..585537553360
--- /dev/null
+++ b/java/jgraphx/distinfo
@@ -0,0 +1,3 @@
+MD5 (jgraphx-1_2_0_5.zip) = bd788292a52506d817efae43f22362c9
+SHA256 (jgraphx-1_2_0_5.zip) = b57b677f4abb1b0153d23da5ca8afe74c0335ab25e6d7d40be52a93a3d98b7b0
+SIZE (jgraphx-1_2_0_5.zip) = 3032608
diff --git a/java/jgraphx/pkg-descr b/java/jgraphx/pkg-descr
new file mode 100644
index 000000000000..1fcf0bc28b4c
--- /dev/null
+++ b/java/jgraphx/pkg-descr
@@ -0,0 +1,11 @@
+JGraph is the most powerful, lightweight, feature-rich, and thoroughly
+documented open-source graph component available for Java. It is accompanied
+by JGraphpad, the first free diagram editor for Java that offers XML, Drag and
+Drop and much more!
+
+With the JGraph zoomable component, you can display objects and relations
+(networks) in any Swing UI. JGraph can also be used on the server-side, for
+example to read a GXL graph, apply a custom layout algorithm, and return the
+result as a HTML image map.
+
+WWW: http://www.jgraph.com/jgraphx.html