aboutsummaryrefslogtreecommitdiffstats
path: root/java/jre
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2002-11-12 05:22:05 +0800
committerglewis <glewis@FreeBSD.org>2002-11-12 05:22:05 +0800
commit663ae76a5bcad5db422ddc1bbfd5d90efa381990 (patch)
tree9c13a3374d803f30bbecdf5e464a566486202f07 /java/jre
parentdcffd9bb21a321ea33cdc3e866e5d62193d7e59a (diff)
downloadfreebsd-ports-gnome-663ae76a5bcad5db422ddc1bbfd5d90efa381990.tar.gz
freebsd-ports-gnome-663ae76a5bcad5db422ddc1bbfd5d90efa381990.tar.zst
freebsd-ports-gnome-663ae76a5bcad5db422ddc1bbfd5d90efa381990.zip
Fix user and group ownership of the installed files when they have been
built by someone other than root. Instead of moving the files with tar, move them with cpio and set up ownership. PR: 36411 (more ports still to go) Submitted by: alane
Diffstat (limited to 'java/jre')
-rw-r--r--java/jre/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/java/jre/Makefile b/java/jre/Makefile
index 3a32046bcc5c..39465b74def4 100644
--- a/java/jre/Makefile
+++ b/java/jre/Makefile
@@ -37,6 +37,8 @@ STRIPFILES= bin/i386/green_threads/jre \
lib/i386/green_threads/libsysresource.so \
lib/i386/green_threads/libzip.so
+CPIO?= /usr/bin/cpio
+
.include <bsd.port.pre.mk>
.if ${PORTOBJFORMAT} == "aout"
@@ -55,8 +57,8 @@ do-install:
${MKDIR} ${PREFIX}/jre${JRE_VERSION}
${MKDIR} ${PREFIX}/share/java/classes
${MKDIR} ${PREFIX}/share/doc/java
- (cd ${WRKSRC} && ${TAR} -c -f - .) \
- | (cd ${PREFIX}/jre${JRE_VERSION} && ${TAR} --unlink -x -f -)
+ cd ${WRKSRC} && ${FIND} . \
+ | ${CPIO} -pdmu -R ${LIBOWN}:${LIBGRP} ${PREFIX}/jre${JRE_VERSION}
cd ${PREFIX}/jre${JRE_VERSION}/bin && \
${LN} -sf .java_wrapper java && \
cd i386/green_threads && \