aboutsummaryrefslogtreecommitdiffstats
path: root/java/linux-ibm-jdk13
diff options
context:
space:
mode:
authorznerd <znerd@FreeBSD.org>2002-10-10 16:38:39 +0800
committerznerd <znerd@FreeBSD.org>2002-10-10 16:38:39 +0800
commit5f5179de26d38781425a4067cd0fb4dcd4f0409d (patch)
tree4721689e202a1cda58ea6eaf35e5f5fb64d50f87 /java/linux-ibm-jdk13
parent73eb630512cb408be8c7cceedfdaad5655c57930 (diff)
downloadfreebsd-ports-gnome-5f5179de26d38781425a4067cd0fb4dcd4f0409d.tar.gz
freebsd-ports-gnome-5f5179de26d38781425a4067cd0fb4dcd4f0409d.tar.zst
freebsd-ports-gnome-5f5179de26d38781425a4067cd0fb4dcd4f0409d.zip
Not using IGNORE anymore to avoid package building.
.if defined(BATCH) || defined(PACKAGE_BUILDING) IGNORE= "You can not legally distribute binaries" .endif This was superfluous and inhibiting package builds of things that depend on the port. Having RESTRICTED and NO_CDROM is enough to ensure that a package will not appear on the FTP site or a CDROM (it will be built and used as a basis for other packages to build with, but will be deleted at the end of the build run). Requested by: kris Reviewed by: portmgr (silence) PR: 42758
Diffstat (limited to 'java/linux-ibm-jdk13')
-rw-r--r--java/linux-ibm-jdk13/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/java/linux-ibm-jdk13/Makefile b/java/linux-ibm-jdk13/Makefile
index d853f57d70e0..91652c2ff24a 100644
--- a/java/linux-ibm-jdk13/Makefile
+++ b/java/linux-ibm-jdk13/Makefile
@@ -29,7 +29,7 @@ ONLY_FOR_ARCHS= i386
APP_HOME?= ${PREFIX}/${PKGBASE}${PORTVERSION}
LINUX_SH?= ${LINUXBASE}/bin/sh
-NO_CDROM= "License doesn\'t allow distribution with fee"
+NO_CDROM= "License does not allow distribution with fee"
RESTRICTED= "Redistribution of repackaged binaries not permitted"
DOWNLOAD_URL= http://www6.software.ibm.com/dl/dklx130/dklx130-i?S_PKG=ia32ww
@@ -42,16 +42,12 @@ RUN_DEPENDS+= ${X11BASE}/lib/X11/fonts/TrueType/wadalab-gothic.ttf:${PORTSDIR}/j
PLIST_SUB+= JAPANESE="@comment "
.endif
-.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute binaries"
-.endif
-
-.include <bsd.port.pre.mk>
-
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
IGNORE=You must manually fetch the IBM Java SDK ${JDK_VERSION} for Linux archive (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again.
.endif
+.include <bsd.port.pre.mk>
+
post-patch:
@for shfn in `${GREP} -r '^#!/bin/sh' ${WRKSRC}|${AWK} -F: '{print $$1}'`; do \
if [ ! -h $$shfn ]; then \