aboutsummaryrefslogtreecommitdiffstats
path: root/java/linux-jdk
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2000-12-15 16:01:52 +0800
committersobomax <sobomax@FreeBSD.org>2000-12-15 16:01:52 +0800
commite7d950fc3d84cc8ed1d8187a3d27b6ceb8e2d48e (patch)
treeb809436f118f66857ca6c686da413904379e8b17 /java/linux-jdk
parent1a81a2661187677d4958e59505f836f17aad5081 (diff)
downloadfreebsd-ports-gnome-e7d950fc3d84cc8ed1d8187a3d27b6ceb8e2d48e.tar.gz
freebsd-ports-gnome-e7d950fc3d84cc8ed1d8187a3d27b6ceb8e2d48e.tar.zst
freebsd-ports-gnome-e7d950fc3d84cc8ed1d8187a3d27b6ceb8e2d48e.zip
Use `--exclude "*.orig"' tar(1) option instead of removing .orig files after
installation. This should partially close ports/23560 problem. PR: ports/23560
Diffstat (limited to 'java/linux-jdk')
-rw-r--r--java/linux-jdk/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/java/linux-jdk/Makefile b/java/linux-jdk/Makefile
index d73c28c8d967..bce3f710e69e 100644
--- a/java/linux-jdk/Makefile
+++ b/java/linux-jdk/Makefile
@@ -28,9 +28,7 @@ NO_BUILD= yes
do-install:
${MKDIR} ${PREFIX}/linux-jdk1.2.2
- (cd ${WRKSRC} && tar -c -f - .) \
+ (cd ${WRKSRC} && tar --exclude "*.orig" -c -f - .) \
| (cd ${PREFIX}/linux-jdk1.2.2 && tar fx -)
- ${RM} ${PREFIX}/linux-jdk1.2.2/bin/.java_wrapper.orig
- ${RM} ${PREFIX}/linux-jdk1.2.2/jre/bin/.java_wrapper.orig
.include <bsd.port.mk>