aboutsummaryrefslogtreecommitdiffstats
path: root/java/linux-sun-jdk16
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2005-05-18 04:57:51 +0800
committerglewis <glewis@FreeBSD.org>2005-05-18 04:57:51 +0800
commitaee76b0fb0c1d6b7c4348548299ffdc18f77614d (patch)
treec4c044f046eecc16296dc87b154145a982f93209 /java/linux-sun-jdk16
parent2aad5ee1f64d55d3a9b0fce837c05885b080c069 (diff)
downloadfreebsd-ports-gnome-aee76b0fb0c1d6b7c4348548299ffdc18f77614d.tar.gz
freebsd-ports-gnome-aee76b0fb0c1d6b7c4348548299ffdc18f77614d.tar.zst
freebsd-ports-gnome-aee76b0fb0c1d6b7c4348548299ffdc18f77614d.zip
. This port is working well enough for me under 5.4 that I can run
graphical applications with it, so restrict the IGNORE setting regarding bad system calls to earlier versions of FreeBSD. One suspects that the actual change to fix things happened sometime earlier in 5.x, but until we figure out exactly what change enabled it or have empirical evidence regarding this 5.4 is a good cutoff.
Diffstat (limited to 'java/linux-sun-jdk16')
-rw-r--r--java/linux-sun-jdk16/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/java/linux-sun-jdk16/Makefile b/java/linux-sun-jdk16/Makefile
index 830e17fd6995..cee762130cd5 100644
--- a/java/linux-sun-jdk16/Makefile
+++ b/java/linux-sun-jdk16/Makefile
@@ -40,10 +40,12 @@ APP_HOME= ${PREFIX}/${PKGNAMEPREFIX}${PORTNAME}${JDK_VERSION}
PACKED_JARS= lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/javaws/javaws.jar
UNPACK_CMD= ${APP_HOME}/bin/unpack200
-IGNORE= does not run (core dumps: Bad System Call)
-
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 504000
+IGNORE= does not run (core dumps: Bad System Call)
+.endif
+
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE?=You must manually fetch the J2SE SDK self-extracting file for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif