aboutsummaryrefslogtreecommitdiffstats
path: root/java/linux-sun-jdk17/Makefile
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2012-05-02 04:05:54 +0800
committerjkim <jkim@FreeBSD.org>2012-05-02 04:05:54 +0800
commit2059a9baf2d9c29f6d7480f36c992a7b5f19a30c (patch)
tree0f08ccc5fd8dcdc687875b1636a9814a33470489 /java/linux-sun-jdk17/Makefile
parent8f98165c41adc522be1d4184e0b635827c0e0141 (diff)
downloadfreebsd-ports-gnome-2059a9baf2d9c29f6d7480f36c992a7b5f19a30c.tar.gz
freebsd-ports-gnome-2059a9baf2d9c29f6d7480f36c992a7b5f19a30c.tar.zst
freebsd-ports-gnome-2059a9baf2d9c29f6d7480f36c992a7b5f19a30c.zip
Add an option to install demos and samples. Turned off by default.
Diffstat (limited to 'java/linux-sun-jdk17/Makefile')
-rw-r--r--java/linux-sun-jdk17/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/java/linux-sun-jdk17/Makefile b/java/linux-sun-jdk17/Makefile
index ee320d1f7b03..dcdd1d7b5934 100644
--- a/java/linux-sun-jdk17/Makefile
+++ b/java/linux-sun-jdk17/Makefile
@@ -17,6 +17,8 @@ COMMENT= Oracle Java 7 Development Kit for Linux
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
+OPTIONS= DEMO "Install demos and samples" off
+
NO_CDROM= License does not allow distribution with fee
RESTRICTED= Redistribution of repackaged binaries not permitted
LATEST_LINK= linux-sun-jdk17
@@ -46,6 +48,16 @@ BIN_DIRS= bin jre/bin
IGNORE?=You must manually fetch the J2SE SDK download for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif
+.if defined(WITH_DEMO)
+.if !exists(${DISTDIR}/${DISTNAME}-demos${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
+IGNORE?=You must manually fetch the J2SE demos and samples for the Linux platform (${DISTNAME}-demos${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
+.endif
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}-demos${EXTRACT_SUFX}
+PLIST_SUB+= DEMO=""
+.else
+PLIST_SUB+= DEMO="@comment "
+.endif
+
pre-everything::
@${CAT} ${PKGMESSAGE}