aboutsummaryrefslogtreecommitdiffstats
path: root/java/netbeans
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-07-29 05:48:05 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-07-29 05:48:05 +0800
commitc822a5a183ab602d2963008e7540d41047f3b083 (patch)
treecbe247a2926a53df5f82f98e8cf1b75d11e2198d /java/netbeans
parent8fc56b93cbaebf7c1f845034a1d026e9a53f947b (diff)
downloadfreebsd-ports-gnome-c822a5a183ab602d2963008e7540d41047f3b083.tar.gz
freebsd-ports-gnome-c822a5a183ab602d2963008e7540d41047f3b083.tar.zst
freebsd-ports-gnome-c822a5a183ab602d2963008e7540d41047f3b083.zip
- Fix shebangs
Approved by: portmgr blanket MFH: 2015Q3 (blanket)
Diffstat (limited to 'java/netbeans')
-rw-r--r--java/netbeans/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/java/netbeans/Makefile b/java/netbeans/Makefile
index db6c6289d9e0..b06d57d0c5a0 100644
--- a/java/netbeans/Makefile
+++ b/java/netbeans/Makefile
@@ -3,6 +3,7 @@
PORTNAME= netbeans
PORTVERSION= 8.0.2
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.netbeans.org/netbeans/${PORTVERSION}/final/zip/ \
http://dlc.sun.com.edgesuite.net/netbeans/${PORTVERSION}/final/zip/
@@ -14,7 +15,11 @@ COMMENT= Modular, standards-based integrated development environment
LICENSE= CDDL GPLv2
LICENSE_COMB= dual
-USES= zip
+USES= shebangfix zip
+SHEBANG_FILES= extide/ant/bin/antRun.pl \
+ extide/ant/bin/complete-ant-cmd.pl \
+ extide/ant/bin/runant.pl \
+ extide/ant/bin/runant.py
USE_JAVA= yes
JAVA_VERSION= 1.7+
NO_BUILD= yes