aboutsummaryrefslogtreecommitdiffstats
path: root/java/openjdk8
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-01-24 23:07:39 +0800
committerantoine <antoine@FreeBSD.org>2015-01-24 23:07:39 +0800
commitefdf659d4a6e4fd3ac42c75ee835fc22037e29ab (patch)
treebf67c1bb6ae5b2f8e4074d102338a30cdf8b4cd8 /java/openjdk8
parent9aacbad58fc52aedc2b94701fba20c62fef1e7bd (diff)
downloadfreebsd-ports-gnome-efdf659d4a6e4fd3ac42c75ee835fc22037e29ab.tar.gz
freebsd-ports-gnome-efdf659d4a6e4fd3ac42c75ee835fc22037e29ab.tar.zst
freebsd-ports-gnome-efdf659d4a6e4fd3ac42c75ee835fc22037e29ab.zip
Switch some dependencies from a directory name or a file generated by pkg-install
to a package name, as the former can't be attributed to a package
Diffstat (limited to 'java/openjdk8')
-rw-r--r--java/openjdk8/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/java/openjdk8/Makefile b/java/openjdk8/Makefile
index 2bfa0c571614..86ee4bf87a48 100644
--- a/java/openjdk8/Makefile
+++ b/java/openjdk8/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libgif.so:${PORTSDIR}/graphics/giflib
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${LOCALBASE}/lib/X11/fonts/dejavu:${PORTSDIR}/x11-fonts/dejavu
+ dejavu>0:${PORTSDIR}/x11-fonts/dejavu
USES= compiler:features dos2unix gmake iconv pkgconfig shebangfix
USE_AUTOTOOLS= autoconf
@@ -105,7 +105,7 @@ POLICY_DESC= Install the Unlimited Strength Policy Files
TZUPDATE_DESC= Update the time zone data
POLICY_CONFIGURE_ENABLE=unlimited-crypto
-TZUPDATE_RUN_DEPENDS= ${LOCALBASE}/share/java/zi:${PORTSDIR}/java/java-zoneinfo
+TZUPDATE_RUN_DEPENDS= java-zoneinfo>0:${PORTSDIR}/java/java-zoneinfo
JAVAVMS_COMMENT= OpenJDK${JDK_MAJOR_VERSION}