aboutsummaryrefslogtreecommitdiffstats
path: root/java/phpeclipse
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-12-03 04:34:28 +0800
committeritetcu <itetcu@FreeBSD.org>2006-12-03 04:34:28 +0800
commitf5b1208aa0496e4bf33b46a75854766ec0889649 (patch)
tree14c12b116109755655a8711f9671b0d5d4513996 /java/phpeclipse
parent01d816cff333d02bbfa2a6f4372e018af30ca907 (diff)
downloadfreebsd-ports-gnome-f5b1208aa0496e4bf33b46a75854766ec0889649.tar.gz
freebsd-ports-gnome-f5b1208aa0496e4bf33b46a75854766ec0889649.tar.zst
freebsd-ports-gnome-f5b1208aa0496e4bf33b46a75854766ec0889649.zip
- portlint
PR: ports/105455 Submitted by: Dominic Fandrey (maintainer)
Diffstat (limited to 'java/phpeclipse')
-rw-r--r--java/phpeclipse/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/java/phpeclipse/Makefile b/java/phpeclipse/Makefile
index 5c3301a1e89e..4d3f6e70913d 100644
--- a/java/phpeclipse/Makefile
+++ b/java/phpeclipse/Makefile
@@ -15,12 +15,12 @@ DISTNAME= net.sourceforge.${PORTNAME}_${PORTVERSION}.bin.dist
MAINTAINER= lon_kamikaze@gmx.de
COMMENT= PHP Eclipse adds PHP support to the Eclipse IDE Framework
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
PLIST_SUB= VER=${PORTVERSION}
PLUGIN_PATHS= features plugins
-RUN_DEPENDS= ${LOCALBASE}/bin/eclipse:${PORTSDIR}/java/eclipse
-
NO_BUILD= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
@@ -33,12 +33,12 @@ do-install:
@${CP} -r ${WRKSRC}/${_path}/* ${ECLIPSE}/${_path}/
.endfor
-plist: patch
+plist: build
@${ECHO} "===> Rebuilding PLIST."
@${TOUCH} ${PLIST}
@${RM} ${PLIST}
.for _path in ${PLUGIN_PATHS}
- @${FIND} ${WRKSRC}/${_path}/ -type f \
+ @${FIND} ${WRKSRC}/${_path}/ -not -type d \
| ${SED} "s|${WRKSRC}|eclipse|1" \
| ${SED} "s|${PORTVERSION}|%%VER%%|g" \
>> ${PLIST}