aboutsummaryrefslogtreecommitdiffstats
path: root/java/simplicity/Makefile
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-06-16 21:37:04 +0800
committerdaichi <daichi@FreeBSD.org>2003-06-16 21:37:04 +0800
commit692bdd2c8a593af6172de9b5153e94a6d191dcc9 (patch)
tree684093cd921b8e238b8d16ca75a7eeb33a15809b /java/simplicity/Makefile
parentd3a65608d19f70f6ece7b58bb299bdefe3cc1068 (diff)
downloadfreebsd-ports-gnome-692bdd2c8a593af6172de9b5153e94a6d191dcc9.tar.gz
freebsd-ports-gnome-692bdd2c8a593af6172de9b5153e94a6d191dcc9.tar.zst
freebsd-ports-gnome-692bdd2c8a593af6172de9b5153e94a6d191dcc9.zip
New port added, thanks!
PR: 45275 Submitted by: Scott Lambert <lambert@lambertfam.org>
Diffstat (limited to 'java/simplicity/Makefile')
-rw-r--r--java/simplicity/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/java/simplicity/Makefile b/java/simplicity/Makefile
new file mode 100644
index 000000000000..4c3b924d6f8c
--- /dev/null
+++ b/java/simplicity/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: Simplicity for Java
+# Date created: 13 November 2002
+# Whom: Scott Lambert <lambert@lambertfam.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= simplicity
+PORTVERSION= 1.2.6b
+CATEGORIES= java devel
+MASTER_SITES= # http://www.datarepresentations.com/products/simplicity/
+DISTNAME= simpjava
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Extremely powerful and extremely simple RAD IDE for Java
+
+BUILD_DEPENDS= ${JAVAVM}:${PORTSDIR}/java/jdk13
+RUN_DEPENDS= ${JAVAVM}:${PORTSDIR}/java/jdk13
+
+JDK13DIR?= ${LOCALBASE}/jdk1.3.1
+JAVAVM= ${JDK13DIR}/bin/java
+
+RESTRICTED= "Restrictive license"
+USE_XLIB= yes
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/Simplicity
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= You must manually fetch the source distribution (${DISTFILES}) from http://www.datarepresentations.com/products/simplicity/download.shtml (registration required), place it in ${DISTDIR} and then run make again
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,%%%PREFIX%%%,${PREFIX}\/share\/java," -e "s,%%%JAVAVM%%%,${JAVAVM}," ${WRKSRC}/Simplicity
+
+do-install:
+ @${CP} -r ${WRKDIR}/Simplicity ${PREFIX}/share/java
+ @${INSTALL_SCRIPT} ${WRKDIR}/Simplicity/Simplicity ${PREFIX}/bin/Simplicity
+
+post-install:
+.if (NON-PURE_JAVA_OK)
+ #@install the NotPureJava/datarep_common.jar in place of datarep_common.jar
+ #@{CP} ${PREFIX}/share/java/Simplicity/datrep_common.jar ${PREFIX}/share/java/Simplicity/datarep_common.jar.purejava.backup
+ #@{CP} ${PREFIX}/share/java/Simplicity/NotPureJava/datrep_common.jar ${PREFIX}/share/java/Simplicity/datarep_common.jar
+.endif
+
+.include <bsd.port.post.mk>