aboutsummaryrefslogtreecommitdiffstats
path: root/java/veditor
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-12-09 21:00:39 +0800
committermiwi <miwi@FreeBSD.org>2006-12-09 21:00:39 +0800
commite13c4e34bd0f46788903d12c46a6545b72c5d3d3 (patch)
tree9aaf9b6b33f171f56a6e0de55e485cddd954b1f7 /java/veditor
parent6c954e6d53dc1f07981fc89a3a01dff01cfc8650 (diff)
downloadfreebsd-ports-gnome-e13c4e34bd0f46788903d12c46a6545b72c5d3d3.tar.gz
freebsd-ports-gnome-e13c4e34bd0f46788903d12c46a6545b72c5d3d3.tar.zst
freebsd-ports-gnome-e13c4e34bd0f46788903d12c46a6545b72c5d3d3.zip
Eclipse Verilog editor provides Verilog (IEEE-1364) and VHDL language
specific features on Eclipse IDE. It helps coding and debugging in hardware development based on Verilog or VHDL. WWW: http://veditor.sourceforge.net/ PR: ports/105450 Submitted by: lon_kamikaze at gmx.de
Diffstat (limited to 'java/veditor')
-rw-r--r--java/veditor/Makefile59
-rw-r--r--java/veditor/distinfo3
-rw-r--r--java/veditor/pkg-descr5
-rw-r--r--java/veditor/pkg-plist13
4 files changed, 80 insertions, 0 deletions
diff --git a/java/veditor/Makefile b/java/veditor/Makefile
new file mode 100644
index 000000000000..01c20d01faeb
--- /dev/null
+++ b/java/veditor/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: veditor
+# Date created: 19 Oct 2006
+# Whom: lon_kamikaze@gmx.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= veditor
+PORTVERSION= 0.5.0
+CATEGORIES= java cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= net.sourceforge.${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= lon_kamikaze@gmx.de
+COMMENT= A Verilog and VHDL editor plugin for eclipse
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
+.if defined(WITH_VERILOG)
+RUN_DEPENDS+= iverilog:${PORTSDIR}/cad/iverilog
+.endif
+
+.if defined(WITH_VHDL)
+RUN_DEPENDS+= freehdl-v2cc:${PORTSDIR}/cad/freehdl
+.endif
+
+OPTIONS= VERILOG "Support Verilog with Icarus Verilog" On \
+ VHDL "Support VHDL with FreeHDL" On
+
+PLIST_SUB= VER=${PORTVERSION}
+
+NO_BUILD= yes
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+
+ECLIPSE= ${PREFIX}/eclipse
+PLUGINS= plugins
+
+do-install:
+ @${MKDIR} ${ECLIPSE}/${PLUGINS}
+ @${CP} -r ${WRKSRC}/${PLUGINS}/* ${ECLIPSE}/${PLUGINS}/
+
+plist: build
+ @${ECHO} "===> Rebuilding PLIST."
+ @${TOUCH} ${PLIST}
+ @${RM} ${PLIST}
+ @${FIND} -d ${WRKSRC}/${PLUGINS}/ -not -type d \
+ | ${SED} "s|${WRKSRC}|eclipse|1" \
+ | ${SED} "s|${PORTVERSION}|%%VER%%|g" \
+ >> ${PLIST}
+ @${FIND} -d ${WRKSRC}/${PLUGINS}/ -mindepth 1 -type d \
+ | ${SED} "s|${WRKSRC}|@dirrm eclipse|1" \
+ | ${SED} "s|${PORTVERSION}|%%VER%%|g" \
+ >> ${PLIST}
+ @${ECHO} "@dirrmtry eclipse/${PLUGINS}" >> ${PLIST}
+ @${ECHO} "@dirrmtry eclipse" >> ${PLIST}
+
+.include <bsd.port.mk>
diff --git a/java/veditor/distinfo b/java/veditor/distinfo
new file mode 100644
index 000000000000..2d7dc8e8f1eb
--- /dev/null
+++ b/java/veditor/distinfo
@@ -0,0 +1,3 @@
+MD5 (net.sourceforge.veditor_0.5.0.zip) = 4ae033914f44b90fb9a7c55ffa21edc3
+SHA256 (net.sourceforge.veditor_0.5.0.zip) = f1adf6620f7e5154b791a05541b7794889988a06ef895a3b146467c31a5dcade
+SIZE (net.sourceforge.veditor_0.5.0.zip) = 181378
diff --git a/java/veditor/pkg-descr b/java/veditor/pkg-descr
new file mode 100644
index 000000000000..74e4787a0358
--- /dev/null
+++ b/java/veditor/pkg-descr
@@ -0,0 +1,5 @@
+Eclipse Verilog editor provides Verilog (IEEE-1364) and VHDL language
+specific features on Eclipse IDE. It helps coding and debugging in hardware
+development based on Verilog or VHDL.
+
+WWW: http://veditor.sourceforge.net/
diff --git a/java/veditor/pkg-plist b/java/veditor/pkg-plist
new file mode 100644
index 000000000000..af9e34e70d23
--- /dev/null
+++ b/java/veditor/pkg-plist
@@ -0,0 +1,13 @@
+eclipse/plugins/net.sourceforge.veditor_%%VER%%/META-INF/MANIFEST.MF
+eclipse/plugins/net.sourceforge.veditor_%%VER%%/icons/hierarchy.gif
+eclipse/plugins/net.sourceforge.veditor_%%VER%%/icons/ovr.gif
+eclipse/plugins/net.sourceforge.veditor_%%VER%%/icons/pers.gif
+eclipse/plugins/net.sourceforge.veditor_%%VER%%/icons/vsrc.gif
+eclipse/plugins/net.sourceforge.veditor_%%VER%%/about.html
+eclipse/plugins/net.sourceforge.veditor_%%VER%%/plugin.xml
+eclipse/plugins/net.sourceforge.veditor_%%VER%%/veditor.jar
+@dirrm eclipse/plugins/net.sourceforge.veditor_%%VER%%/META-INF
+@dirrm eclipse/plugins/net.sourceforge.veditor_%%VER%%/icons
+@dirrm eclipse/plugins/net.sourceforge.veditor_%%VER%%
+@dirrmtry eclipse/plugins
+@dirrmtry eclipse