aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2012-05-27 11:51:15 +0800
committerglewis <glewis@FreeBSD.org>2012-05-27 11:51:15 +0800
commit27f3622327e44c7634093349bac5ba1d27ea9f0a (patch)
tree45beb2994195fc5f35bf99a278b99fc09d4396d7 /java
parent55b48ae5eb7f0b018602379d05a3f37ef0eba63b (diff)
downloadfreebsd-ports-gnome-27f3622327e44c7634093349bac5ba1d27ea9f0a.tar.gz
freebsd-ports-gnome-27f3622327e44c7634093349bac5ba1d27ea9f0a.tar.zst
freebsd-ports-gnome-27f3622327e44c7634093349bac5ba1d27ea9f0a.zip
. Specifically reference zip/unzip in ${LOCALBASE}/bin, since that is where
the JDK build looks for them, but FreeBSD 9.x has them available in /usr/bin. Adjusting the JDK check is a harder fix, this will get things building again on 9.x quickly. PR: 166996
Diffstat (limited to 'java')
-rw-r--r--java/openjdk6/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/java/openjdk6/Makefile b/java/openjdk6/Makefile
index 551ad9866771..2c05ba1a8992 100644
--- a/java/openjdk6/Makefile
+++ b/java/openjdk6/Makefile
@@ -31,8 +31,8 @@ COMMENT= Oracle's Java 6 virtual machine release under the GPL v2
LICENSE= GPLv2
-BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
- unzip:${PORTSDIR}/archivers/unzip \
+BUILD_DEPENDS= ${LOCALBASE}/bin/zip:${PORTSDIR}/archivers/zip \
+ ${LOCALBASE}/bin/unzip:${PORTSDIR}/archivers/unzip \
${LOCALBASE}/include/cups/cups.h:${PORTSDIR}/print/cups-client
LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \