aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-17 17:40:22 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-17 17:40:22 +0800
commit6394f26b13dd12429f2b21be1fa7584d1e3f9148 (patch)
tree00143e8299aac34db1d3e81f2c362f41d74ca8a6 /java
parent71073289bb13c448d7d9805c123cff726c9b4f08 (diff)
downloadfreebsd-ports-gnome-6394f26b13dd12429f2b21be1fa7584d1e3f9148.tar.gz
freebsd-ports-gnome-6394f26b13dd12429f2b21be1fa7584d1e3f9148.tar.zst
freebsd-ports-gnome-6394f26b13dd12429f2b21be1fa7584d1e3f9148.zip
Stagify.
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-vep/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/java/eclipse-vep/Makefile b/java/eclipse-vep/Makefile
index c89648b0d060..e1adddbc398f 100644
--- a/java/eclipse-vep/Makefile
+++ b/java/eclipse-vep/Makefile
@@ -26,11 +26,10 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
@(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
@(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
| ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \