aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2012-05-04 14:14:26 +0800
committerglewis <glewis@FreeBSD.org>2012-05-04 14:14:26 +0800
commit71f7eb9789e359f579b1a577e4abda6a05c16cf2 (patch)
tree7d799a958b2ec0d78ccc1fb076b1a664ffbd807f /java
parent9b61a5a9997d7ed41dab41af2269cf49c58cd328 (diff)
downloadfreebsd-ports-gnome-71f7eb9789e359f579b1a577e4abda6a05c16cf2.tar.gz
freebsd-ports-gnome-71f7eb9789e359f579b1a577e4abda6a05c16cf2.tar.zst
freebsd-ports-gnome-71f7eb9789e359f579b1a577e4abda6a05c16cf2.zip
. Add a POLICY option to install the unlimited strength policy files and
default it to on since I can't imagine why anyone would deliberately want the limited strength versions given a choice. Cribbed from java/openjdk6
Diffstat (limited to 'java')
-rw-r--r--java/openjdk7/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index 5745548a485c..a0ea4f77a0dd 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${PORT_MINOR_VERSION}.${PORT_BUILD_NUMBER}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk7u2/promoted/b${JDK_BUILD_NUMBER}/ \
http://download.java.net/jaxp/1.4.5/:jaxp \
@@ -34,7 +35,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_ZIP= YES
MAKE_JOBS_UNSAFE= YES
-OPTIONS= TZUPDATE "Update the time zone data" on
+OPTIONS= POLICY "Install the Unlimited Strength Policy Files" on \
+ TZUPDATE "Update the time zone data" on
JDK_MAJOR_VERSION= 7
JDK_MINOR_VERSION= 2
@@ -154,6 +156,10 @@ post-patch:
${WRKSRC}/hotspot/src/os/bsd/vm/os_bsd.cpp
@${REINPLACE_CMD} 's|build-policy install-limited|build-policy install-unlimited|' \
${WRKSRC}/jdk/make/javax/crypto/Makefile
+.if defined(WITH_POLICY)
+ @${REINPLACE_CMD} 's|build-policy install-limited|build-policy install-unlimited|' \
+ ${WRKSRC}/jdk/make/javax/crypto/Makefile
+.endif
.if defined(WITH_TZUPDATE)
pre-install: