aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2012-08-28 01:43:38 +0800
committerjkim <jkim@FreeBSD.org>2012-08-28 01:43:38 +0800
commita3e617d915c8763c8bd08887c1b39e82ea4137ec (patch)
tree0d6d7b08eeb0160c173ad77976ecedf9b9ad3695 /java
parent1dc8bc32b624baeee38222de45f2cdcd0f0c4224 (diff)
downloadfreebsd-ports-gnome-a3e617d915c8763c8bd08887c1b39e82ea4137ec.tar.gz
freebsd-ports-gnome-a3e617d915c8763c8bd08887c1b39e82ea4137ec.tar.zst
freebsd-ports-gnome-a3e617d915c8763c8bd08887c1b39e82ea4137ec.zip
Allow java/openjdk7 to build and execute Java plugin. A necessary patch for
OpenJDK7 was committed as r303173.
Diffstat (limited to 'java')
-rw-r--r--java/icedtea-web/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index a1df183c7a64..e8fa8c619b10 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -21,7 +21,7 @@ USE_GMAKE= yes
USE_JAVA= yes
JAVA_OS= native
JAVA_VENDOR= openjdk
-JAVA_VERSION= 1.6
+JAVA_VERSION= 1.6+
USE_XORG= x11
OPTIONS_DEFINE= PLUGIN RHINO TEST
@@ -90,12 +90,14 @@ post-patch:
${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/launcher/javaws.in
+.if ${JAVA_PORT_VERSION} == "1.6.0"
pre-extract:
@${ECHO_MSG}
@${ECHO_MSG} "IMPORTANT: To build IcedTea-Web ${PORTVERSION}, you have to turn on 'ICEDTEA' option"
- @${ECHO_MSG} "for java/openjdk6 (default). Otherwise, it will neither build nor work."
+ @${ECHO_MSG} "for ${JAVA_PORT} (default). Otherwise, it will neither build nor work."
@${ECHO_MSG}
@sleep 10
+.endif
.if ${PORT_OPTIONS:MTEST}
post-build: