aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2016-12-01 04:37:56 +0800
committerbsam <bsam@FreeBSD.org>2016-12-01 04:37:56 +0800
commitb5351cd26af7508ee52bdf0a7cf1aa1e597a26d7 (patch)
treed77fb67db73d69b9842b0b6a84e6b148d7710999 /java
parentf3cc5220e0ce44108ce2e731748597271a7d8bf2 (diff)
downloadfreebsd-ports-gnome-b5351cd26af7508ee52bdf0a7cf1aa1e597a26d7.tar.gz
freebsd-ports-gnome-b5351cd26af7508ee52bdf0a7cf1aa1e597a26d7.tar.zst
freebsd-ports-gnome-b5351cd26af7508ee52bdf0a7cf1aa1e597a26d7.zip
java/intellij: Remove non-native jar libraries.
Reported by: Caspar Schutijser <caspar@schutijser.com> (via email; thanks Caspar! My email answer seems to end up at your spam filter)
Diffstat (limited to 'java')
-rw-r--r--java/intellij/Makefile10
-rw-r--r--java/intellij/pkg-plist6
2 files changed, 4 insertions, 12 deletions
diff --git a/java/intellij/Makefile b/java/intellij/Makefile
index f396cc1d3816..42f9af92a84e 100644
--- a/java/intellij/Makefile
+++ b/java/intellij/Makefile
@@ -6,6 +6,7 @@
PORTNAME= intellij
PORTVERSION= 2016.3
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= https://download.jetbrains.com/idea/ \
http://download.jetbrains.com/idea/
@@ -42,12 +43,9 @@ do-install:
${STAGEDIR}${IDEA_HOME}/bin/fsnotifier64 \
${STAGEDIR}${IDEA_HOME}/bin/libbreakgen.so \
${STAGEDIR}${IDEA_HOME}/bin/libbreakgen64.so \
- ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-linux-amd64-0.10.jar \
- ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-linux-i386-0.10.jar \
- ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-osx-amd64-0.10.jar \
- ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-osx-i386-0.10.jar \
- ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-windows-amd64-0.10.jar \
- ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-windows-i386-0.10.jar
+ ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-linux-*.jar \
+ ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-osx-*.jar \
+ ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-windows-*.jar \
# Remove the bundled native Pty4J support libraries, they are replaced
# by java/intellij-pty4j
@${RM} -r ${STAGEDIR}${IDEA_HOME}/lib/libpty
diff --git a/java/intellij/pkg-plist b/java/intellij/pkg-plist
index b0240b186429..c3178bc06b23 100644
--- a/java/intellij/pkg-plist
+++ b/java/intellij/pkg-plist
@@ -10079,12 +10079,6 @@ share/applications/idea.desktop
%%IDEA_HOME%%/plugins/gradle/lib/native-platform-0.11.jar
%%IDEA_HOME%%/plugins/gradle/lib/native-platform-freebsd-amd64-0.11.jar
%%IDEA_HOME%%/plugins/gradle/lib/native-platform-freebsd-i386-0.11.jar
-%%IDEA_HOME%%/plugins/gradle/lib/native-platform-linux-amd64-0.11.jar
-%%IDEA_HOME%%/plugins/gradle/lib/native-platform-linux-i386-0.11.jar
-%%IDEA_HOME%%/plugins/gradle/lib/native-platform-osx-amd64-0.11.jar
-%%IDEA_HOME%%/plugins/gradle/lib/native-platform-osx-i386-0.11.jar
-%%IDEA_HOME%%/plugins/gradle/lib/native-platform-windows-amd64-0.11.jar
-%%IDEA_HOME%%/plugins/gradle/lib/native-platform-windows-i386-0.11.jar
%%IDEA_HOME%%/plugins/gradle/lib/objenesis-1.2.jar
%%IDEA_HOME%%/plugins/gradle/lib/reflectasm-1.07.jar
%%IDEA_HOME%%/plugins/gradle/lib/resources_en.jar