aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-06-17 18:10:38 +0800
committervanilla <vanilla@FreeBSD.org>2014-06-17 18:10:38 +0800
commitf8419679b2a231022453a0f44ffc76b079122a38 (patch)
tree7a506efbf1092411eea297d944c631f271775dd3 /java
parentbb7c4c0801dd03088a6b27751ddefaf85d637d32 (diff)
downloadfreebsd-ports-gnome-f8419679b2a231022453a0f44ffc76b079122a38.tar.gz
freebsd-ports-gnome-f8419679b2a231022453a0f44ffc76b079122a38.tar.zst
freebsd-ports-gnome-f8419679b2a231022453a0f44ffc76b079122a38.zip
Stagify.
Diffstat (limited to 'java')
-rw-r--r--java/eclipse-lomboz/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/java/eclipse-lomboz/Makefile b/java/eclipse-lomboz/Makefile
index 3dde3511f6f0..55e247961425 100644
--- a/java/eclipse-lomboz/Makefile
+++ b/java/eclipse-lomboz/Makefile
@@ -26,14 +26,13 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>