aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-15 23:45:35 +0800
committeradamw <adamw@FreeBSD.org>2014-07-15 23:45:35 +0800
commitfef257d5b2a2f592abc556b8cb8bd6345be6f045 (patch)
tree47aee1fa27519c0c4d94c0d2c7dca2b0bbd61934 /java
parent9c256fbbe18f389b8718aa167b9fa4e1608b8ca1 (diff)
downloadfreebsd-ports-gnome-fef257d5b2a2f592abc556b8cb8bd6345be6f045.tar.gz
freebsd-ports-gnome-fef257d5b2a2f592abc556b8cb8bd6345be6f045.tar.zst
freebsd-ports-gnome-fef257d5b2a2f592abc556b8cb8bd6345be6f045.zip
Add DOCS to OPTIONS_DEFINE to ports that check for PORT_OPTIONS:MDOCS.
Apologies in advance, I know java drives its short bus very, very slowly through qat. Building these 3 ports will probably wedge it for weeks.
Diffstat (limited to 'java')
-rw-r--r--java/jakarta-commons-beanutils/Makefile2
-rw-r--r--java/jcommon/Makefile2
-rw-r--r--java/jfreechart/Makefile2
3 files changed, 4 insertions, 2 deletions
diff --git a/java/jakarta-commons-beanutils/Makefile b/java/jakarta-commons-beanutils/Makefile
index 485ebbecc9b8..8f9e00448763 100644
--- a/java/jakarta-commons-beanutils/Makefile
+++ b/java/jakarta-commons-beanutils/Makefile
@@ -31,6 +31,8 @@ MAKE_ARGS+= -Dcommons-collections.jar=${JAVALIBDIR}/commons-collections.jar \
JARFILE= ${PORTNAME}.jar
PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
diff --git a/java/jcommon/Makefile b/java/jcommon/Makefile
index a69b2ae913e8..79577b672fd1 100644
--- a/java/jcommon/Makefile
+++ b/java/jcommon/Makefile
@@ -15,7 +15,7 @@ USES= zip
USE_JAVA= yes
JAVA_VERSION= 1.6+
-OPTIONS_DEFINE= COMPILE
+OPTIONS_DEFINE= COMPILE DOCS
OPTIONS_DEFAULT=COMPILE
COMPILE_DESC= Build from source
diff --git a/java/jfreechart/Makefile b/java/jfreechart/Makefile
index 8b0809d51fc3..5491cd5c2e88 100644
--- a/java/jfreechart/Makefile
+++ b/java/jfreechart/Makefile
@@ -16,7 +16,7 @@ RUN_DEPENDS= ${JAVALIBDIR}/jcommon.jar:${PORTSDIR}/java/jcommon
USE_JAVA= yes
JAVA_VERSION= 1.6+
-OPTIONS_DEFINE= COMPILE
+OPTIONS_DEFINE= COMPILE DOCS
OPTIONS_DEFAULT=COMPILE
COMPILE_DESC= Build from source