aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorphantom <phantom@FreeBSD.org>2003-11-12 20:13:35 +0800
committerphantom <phantom@FreeBSD.org>2003-11-12 20:13:35 +0800
commit138119eeae264b0dd587552ac04dfd982887d2f1 (patch)
treeb764ad594c9aa925938799126267f11e2e6ec209 /java
parent42986cf73c992e33984ca17d289a47296bb1a0a2 (diff)
downloadfreebsd-ports-gnome-138119eeae264b0dd587552ac04dfd982887d2f1.tar.gz
freebsd-ports-gnome-138119eeae264b0dd587552ac04dfd982887d2f1.tar.zst
freebsd-ports-gnome-138119eeae264b0dd587552ac04dfd982887d2f1.zip
Add patch to fix build problems on 5.x system reported by many people.
It was last minute change and since this tool (unpack) is not used while building jdk14 port, I did not paid enough attention to test this change at -CURRENT system. Sorry.
Diffstat (limited to 'java')
-rw-r--r--java/jdk14/files/patch-unpack::Makefile13
-rw-r--r--java/jdk15/files/patch-unpack::Makefile13
-rw-r--r--java/jdk16/files/patch-unpack::Makefile13
3 files changed, 39 insertions, 0 deletions
diff --git a/java/jdk14/files/patch-unpack::Makefile b/java/jdk14/files/patch-unpack::Makefile
new file mode 100644
index 000000000000..00bd32da18e8
--- /dev/null
+++ b/java/jdk14/files/patch-unpack::Makefile
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- ../../dj2se/make/tools/pack-unpack/unpack/Makefile.orig Thu Nov 13 13:07:59 2003
++++ ../../dj2se/make/tools/pack-unpack/unpack/Makefile1 Thu Nov 13 13:07:43 2003
+@@ -50,7 +50,7 @@
+ ifeq ($(PLATFORM), bsd)
+ OBJOUTPUT = -o #Caution:the space after the -o is significant!.
+ LNKOUTPUT = $(OBJOUTPUT)
+-LINK = $(CXX)
++LINK = g++
+ else
+ OBJOUTPUT = -o #Caution:the space after the -o is significant!.
+ LNKOUTPUT = $(OBJOUTPUT)
diff --git a/java/jdk15/files/patch-unpack::Makefile b/java/jdk15/files/patch-unpack::Makefile
new file mode 100644
index 000000000000..00bd32da18e8
--- /dev/null
+++ b/java/jdk15/files/patch-unpack::Makefile
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- ../../dj2se/make/tools/pack-unpack/unpack/Makefile.orig Thu Nov 13 13:07:59 2003
++++ ../../dj2se/make/tools/pack-unpack/unpack/Makefile1 Thu Nov 13 13:07:43 2003
+@@ -50,7 +50,7 @@
+ ifeq ($(PLATFORM), bsd)
+ OBJOUTPUT = -o #Caution:the space after the -o is significant!.
+ LNKOUTPUT = $(OBJOUTPUT)
+-LINK = $(CXX)
++LINK = g++
+ else
+ OBJOUTPUT = -o #Caution:the space after the -o is significant!.
+ LNKOUTPUT = $(OBJOUTPUT)
diff --git a/java/jdk16/files/patch-unpack::Makefile b/java/jdk16/files/patch-unpack::Makefile
new file mode 100644
index 000000000000..00bd32da18e8
--- /dev/null
+++ b/java/jdk16/files/patch-unpack::Makefile
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- ../../dj2se/make/tools/pack-unpack/unpack/Makefile.orig Thu Nov 13 13:07:59 2003
++++ ../../dj2se/make/tools/pack-unpack/unpack/Makefile1 Thu Nov 13 13:07:43 2003
+@@ -50,7 +50,7 @@
+ ifeq ($(PLATFORM), bsd)
+ OBJOUTPUT = -o #Caution:the space after the -o is significant!.
+ LNKOUTPUT = $(OBJOUTPUT)
+-LINK = $(CXX)
++LINK = g++
+ else
+ OBJOUTPUT = -o #Caution:the space after the -o is significant!.
+ LNKOUTPUT = $(OBJOUTPUT)