aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2008-01-17 15:51:46 +0800
committerglewis <glewis@FreeBSD.org>2008-01-17 15:51:46 +0800
commit62ab4fea9570b005d2b50df36afad972c7ab255d (patch)
treef46b54029d4932673b74c047d9d5fae379470820 /java
parentf3df145676f681cbc6717efb35531134202b0e9c (diff)
downloadfreebsd-ports-gnome-62ab4fea9570b005d2b50df36afad972c7ab255d.tar.gz
freebsd-ports-gnome-62ab4fea9570b005d2b50df36afad972c7ab255d.tar.zst
freebsd-ports-gnome-62ab4fea9570b005d2b50df36afad972c7ab255d.zip
. Force eclipse to use one of the jdk* ports rather than the diablo-jdk15
port on FreeBSD 7.x and higher as mixing the native 7.x libraries of eclipse and the native 6.x libraries of diablo-jdk is a recipe for trouble. PR: 118115
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile14
-rw-r--r--java/eclipse/files/eclipse.in2
2 files changed, 15 insertions, 1 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index a68efa5a25db..679b5cd1563e 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -7,6 +7,7 @@
PORTNAME= eclipse
PORTVERSION= 3.2.2
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_ECLIPSE}
MASTER_SITE_SUBDIR= R-${PORTVERSION}-200702121330
@@ -60,6 +61,10 @@ MAKE_CAIRO= make_cairo
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 700000
+JAVA_VENDOR= bsdjava
+.endif
+
.if !defined(WITHOUT_MOZILLA)
MAKE_MOZILLA= make_mozilla
BROWSER= ${GECKO}
@@ -125,6 +130,15 @@ do-install:
-e "s,%%JAVA_VERSION%%,${JAVA_VERSION},g" \
-e "s+%%JAVA_OS%%+${JAVA_OS}+g" \
${FILESDIR}/eclipse.in > ${WRKSRC}/eclipse.tmp
+.if defined(JAVA_VENDOR)
+ ${REINPLACE_CMD} \
+ -e "s+%%JAVA_VENDOR_SPECIFICATION%%+JAVA_VENDOR=\"${JAVA_VENDOR}\"+g" \
+ ${WRKSRC}/eclipse.tmp
+.else
+ ${REINPLACE_CMD} \
+ -e "s+%%JAVA_VENDOR_SPECIFICATION%%++g" \
+ ${WRKSRC}/eclipse.tmp
+.endif
${INSTALL_SCRIPT} ${WRKSRC}/eclipse.tmp ${PREFIX}/bin/eclipse
@${SED} \
-e "s+%%ECLIPSE_HOME%%+${PORTDESTDIR}+g" \
diff --git a/java/eclipse/files/eclipse.in b/java/eclipse/files/eclipse.in
index a1c7576eb288..8a2b7e32eb51 100644
--- a/java/eclipse/files/eclipse.in
+++ b/java/eclipse/files/eclipse.in
@@ -46,4 +46,4 @@ if [ ! -x "${ECLIPSE_HOME}/eclipse" ]; then
exit 1
fi
-JAVA_VERSION="%%JAVA_VERSION%%" JAVA_OS="%%JAVA_OS%%" PATH=${JAVA_HOME}/bin:${PATH} exec "${ECLIPSE_HOME}/eclipse" $@
+JAVA_VERSION="%%JAVA_VERSION%%" JAVA_OS="%%JAVA_OS%%" %%JAVA_VENDOR_SPECIFICATION%% PATH=${JAVA_HOME}/bin:${PATH} exec "${ECLIPSE_HOME}/eclipse" $@