aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /java
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-gnome-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'java')
-rw-r--r--java/icedtea-web/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 4c1943239c18..ee4b86a667d7 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -40,10 +40,11 @@ PLIST_FILES= bin/itweb-javaws bin/itweb-settings \
PORTDATA= about.jar about.jnlp netx.jar
PORTDOCS= netx
-BUILD_DEPENDS+= ${LOCALBASE}/bin/zip:${PORTSDIR}/archivers/zip \
- ${LOCALBASE}/bin/pkg-config:${PORTSDIR}/devel/pkg-config
+BUILD_DEPENDS+= ${LOCALBASE}/bin/zip:${PORTSDIR}/archivers/zip
RUN_DEPENDS+= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+USE_PKGCONFIG= yes
+
CONFIGURE_ARGS+=--with-ecj=no --with-jdk-home="${JAVA_HOME}"
.include <bsd.port.pre.mk>