aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
committerade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
commit9291e9a32f6612ca0d4f25bdcb5c417e0451d313 (patch)
tree545e55afde412d844a25f5c03d6d51b17ceeebb9 /java
parenta8a89c37fe338cbff0192ceeef27ccf7a13714a5 (diff)
downloadfreebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.gz
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.zst
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.zip
Whoa there, boy, that's a mighty big commit y'all have there...
Begin autotools sanitization sequence by requiring ports to explicitly specify which version of {libtool,autoconf,automake} they need, erasing the concept of a "system default". For ports-in-waiting: USE_LIBTOOL=YES -> USE_LIBTOOL_VER=13 USE_AUTOCONF=YES -> USE_AUTOCONF_VER=213 USE_AUTOMAKE=YES -> USE_AUTOMAKE_VER=14 Ports attempting to use the old style system after June 1st 2004 will be sorely disappointed.
Diffstat (limited to 'java')
-rw-r--r--java/jmp/Makefile2
-rw-r--r--java/kaffe-devel/Makefile2
-rw-r--r--java/kaffe/Makefile2
-rw-r--r--java/sablevm/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/java/jmp/Makefile b/java/jmp/Makefile
index f26090f0eb36..1ee1bf035a7d 100644
--- a/java/jmp/Makefile
+++ b/java/jmp/Makefile
@@ -32,7 +32,7 @@ LIB_DEPENDS+= gtk-x11-2.0:${PORTSDIR}/x11-toolkits/gtk20
CFLAGS+= -DJMPDEBUG -g
.endif
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GMAKE= yes
USE_JAVA= 1.2+
NEED_JAVAC= yes
diff --git a/java/kaffe-devel/Makefile b/java/kaffe-devel/Makefile
index 39db34069d21..83392a463c41 100644
--- a/java/kaffe-devel/Makefile
+++ b/java/kaffe-devel/Makefile
@@ -30,7 +30,7 @@ WRKSRC= ${WRKDIR}/kaffe-${PORTVERSION}
NOT_FOR_ARCHS= amd64 alpha
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GMAKE= yes
USE_ICONV= yes
LIBTOOLFLAGS=
diff --git a/java/kaffe/Makefile b/java/kaffe/Makefile
index 55666fcc9dab..0fdbb4e430aa 100644
--- a/java/kaffe/Makefile
+++ b/java/kaffe/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
NOT_FOR_ARCHS= amd64
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
LIBTOOLFLAGS=
INSTALLS_SHLIB= yes
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index ed8ae7ca76bc..c1c6ce675e19 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -26,7 +26,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
PATCH_WRKSRC= ${WRKDIR}
PATCH_STRIP= -p1
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
LIBTOOLFILES= ${SABLEVMDIR}/configure ${NATIVEDIR}/configure
USE_GMAKE= yes
INSTALLS_SHLIB= yes