aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorarchie <archie@FreeBSD.org>2004-03-29 05:38:40 +0800
committerarchie <archie@FreeBSD.org>2004-03-29 05:38:40 +0800
commit9f3e076e658a2d3b1b9564355318feabfef8b039 (patch)
treebb71b4f9d8263389a8d605758001044ba3b6f34c /java
parentd6915985e9725d9d82162cb527fad47b544c0fad (diff)
downloadfreebsd-ports-gnome-9f3e076e658a2d3b1b9564355318feabfef8b039.tar.gz
freebsd-ports-gnome-9f3e076e658a2d3b1b9564355318feabfef8b039.tar.zst
freebsd-ports-gnome-9f3e076e658a2d3b1b9564355318feabfef8b039.zip
Build fix for 5.x.
Diffstat (limited to 'java')
-rw-r--r--java/jc/files/patch-ad22
1 files changed, 22 insertions, 0 deletions
diff --git a/java/jc/files/patch-ad b/java/jc/files/patch-ad
new file mode 100644
index 000000000000..47fae4339875
--- /dev/null
+++ b/java/jc/files/patch-ad
@@ -0,0 +1,22 @@
+--- jc-1.0.1/jsrc/Makefile.am.orig Sun Mar 28 15:34:08 2004
++++ jc-1.0.1/jsrc/Makefile.am Sun Mar 28 15:34:20 2004
+@@ -14,7 +14,7 @@
+ ##
+ ## GCC flags for compiling ELF objects
+ ##
+-HOSTGCC_FLAGS= -O2 -g -pipe -fno-common -w -Wall -Waggregate-return -Wcast-align -Wcast-qual -Wchar-subscripts -Wcomment -Wformat -Wimplicit -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wno-long-long -Wparentheses -Wpointer-arith -Wreturn-type -Wshadow -Wstrict-prototypes -Wswitch -Wtrigraphs -Wuninitialized -Wunused -Wwrite-strings -Werror -Wa,-W
++HOSTGCC_FLAGS= -O2 -g -pipe -fno-common -w -Wall -Waggregate-return -Wcast-align -Wcast-qual -Wchar-subscripts -Wcomment -Wformat -Wimplicit -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wno-long-long -Wparentheses -Wpointer-arith -Wreturn-type -Wshadow -Wstrict-prototypes -Wswitch -Wtrigraphs -Wuninitialized -Wunused -Wwrite-strings -Wa,-W
+
+ ##
+ ## Install pre-built source files and compile them
+--- jc-1.0.1/jsrc/Makefile.in.orig Sun Mar 28 15:34:12 2004
++++ jc-1.0.1/jsrc/Makefile.in Sun Mar 28 15:34:22 2004
+@@ -110,7 +110,7 @@
+
+ EXTRA_DIST = jsrc.tgz patterns
+
+-HOSTGCC_FLAGS = -O2 -g -pipe -fno-common -w -Wall -Waggregate-return -Wcast-align -Wcast-qual -Wchar-subscripts -Wcomment -Wformat -Wimplicit -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wno-long-long -Wparentheses -Wpointer-arith -Wreturn-type -Wshadow -Wstrict-prototypes -Wswitch -Wtrigraphs -Wuninitialized -Wunused -Wwrite-strings -Werror -Wa,-W
++HOSTGCC_FLAGS = -O2 -g -pipe -fno-common -w -Wall -Waggregate-return -Wcast-align -Wcast-qual -Wchar-subscripts -Wcomment -Wformat -Wimplicit -Wmissing-declarations -Wmissing-prototypes -Wnested-externs -Wno-long-long -Wparentheses -Wpointer-arith -Wreturn-type -Wshadow -Wstrict-prototypes -Wswitch -Wtrigraphs -Wuninitialized -Wunused -Wwrite-strings -Wa,-W
+
+ CLEANFILES = sources objects patterns
+ subdir = jsrc