aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2013-03-03 13:08:45 +0800
committerglewis <glewis@FreeBSD.org>2013-03-03 13:08:45 +0800
commitae46803c4e5aea61f9c81fe9f96df62bf60ba920 (patch)
treec1e0bcf6c53bd88908afa9267537743425b83dd1 /java
parent0c814f5f45a5900c2927f6b26dbf17f002c79c74 (diff)
downloadfreebsd-ports-gnome-ae46803c4e5aea61f9c81fe9f96df62bf60ba920.tar.gz
freebsd-ports-gnome-ae46803c4e5aea61f9c81fe9f96df62bf60ba920.tar.zst
freebsd-ports-gnome-ae46803c4e5aea61f9c81fe9f96df62bf60ba920.zip
. Use gpatch for patching on older (7.x) versions of FreeBSD.
PR: 175829 Submitted by: Nobuhiro Ban <ban.nobuhiro@gmail.com>
Diffstat (limited to 'java')
-rw-r--r--java/openjdk7/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index 7b2b5d97f876..d244934e32b7 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -135,6 +135,11 @@ BOOTSTRAPJDKDIR?= ${LOCALBASE}/bootstrap-openjdk
BUILD_DEPENDS+= ${BOOTSTRAPJDKDIR}/bin/javac:${PORTSDIR}/java/bootstrap-openjdk
.endif
+.if ${OSVERSION} < 800000
+PATCH_DEPENDS+= gpatch:${PORTSDIR}/devel/patch
+PATCH= gpatch
+.endif
+
post-patch:
@${REINPLACE_CMD} "s|%%LOCALBASE%%|${LOCALBASE}|" \
${WRKSRC}/hotspot/src/os/bsd/vm/os_bsd.cpp