aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
committertijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
commitc06f97c7c46a03f3f6bb887aee3534bece5267a1 (patch)
tree320f49e86d38a480aace5bd0e27c34d6c8f75c2c /java
parent682bd0d0ee3984087ff6a9f3bf4b0552db04d013 (diff)
downloadfreebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.gz
freebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.zst
freebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.zip
Replace USE_AUTOTOOLS=libltdl with an ordinary LIB_DEPENDS in all ports.
There are only 60 such ports so there doesn't need to be a separate keyword or USES for this. Approved by: portmgr (bapt)
Diffstat (limited to 'java')
-rw-r--r--java/sablevm/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index 8ffb0df2c460..10ea4f64cc54 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -12,13 +12,13 @@ COMMENT= Java VM created by McGill University's Sable Research Group
LICENSE= LGPL21
LIB_DEPENDS= libpopt.so:${PORTSDIR}/devel/popt \
- libffi.so:${PORTSDIR}/devel/libffi
+ libffi.so:${PORTSDIR}/devel/libffi \
+ libltdl.so:${PORTSDIR}/devel/libltdl
RUN_DEPENDS= fastjar:${PORTSDIR}/archivers/fastjar
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USES= gettext gmake iconv libtool pkgconfig
-USE_AUTOTOOLS= libltdl
USE_LDCONFIG= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include/${PORTNAME}