aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2014-01-22 16:36:48 +0800
committerale <ale@FreeBSD.org>2014-01-22 16:36:48 +0800
commitc883ce7351f49ab7d33c144d261c5c81274594d3 (patch)
treeb2829dad2baaadbd75e5d8adf343ffb900b665fd /java
parent5c486bad24e0194a5cad1b77a00af0e054fe6030 (diff)
downloadfreebsd-ports-gnome-c883ce7351f49ab7d33c144d261c5c81274594d3.tar.gz
freebsd-ports-gnome-c883ce7351f49ab7d33c144d261c5c81274594d3.tar.zst
freebsd-ports-gnome-c883ce7351f49ab7d33c144d261c5c81274594d3.zip
Support staging.
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile.plugins8
1 files changed, 4 insertions, 4 deletions
diff --git a/java/eclipse/Makefile.plugins b/java/eclipse/Makefile.plugins
index 73dc1993d181..de1e2ea1fcf2 100644
--- a/java/eclipse/Makefile.plugins
+++ b/java/eclipse/Makefile.plugins
@@ -6,8 +6,8 @@ JAVA_OS= native
REPO_DIRS?= features plugins
do-install:
- @${MKDIR} ${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
- @(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
- @(cd ${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
- @(cd ${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d) \
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse
+ @(cd ${WRKSRC}; ${COPYTREE_SHARE} "${REPO_DIRS}" ${STAGEDIR}${PREFIX}/share/eclipse/dropins/${PORTNAME}/eclipse/)
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} -s share/eclipse/dropins/${PORTNAME} -not -type d) >> ${TMPPLIST}
+ @(cd ${STAGEDIR}${PREFIX}; ${FIND} -s -d share/eclipse/dropins/${PORTNAME} -type d) \
| ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}