aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2002-05-28 09:40:07 +0800
committerobrien <obrien@FreeBSD.org>2002-05-28 09:40:07 +0800
commitcae4b16f807df1a798c97cc281999da4167aa8a1 (patch)
tree013ede04ca673b2037be41df7111a8d65fe68cd1 /java
parent4aae402ffe38df40bc4fa0925df7ca3e4c99fc1d (diff)
downloadfreebsd-ports-gnome-cae4b16f807df1a798c97cc281999da4167aa8a1.tar.gz
freebsd-ports-gnome-cae4b16f807df1a798c97cc281999da4167aa8a1.tar.zst
freebsd-ports-gnome-cae4b16f807df1a798c97cc281999da4167aa8a1.zip
Make sure the Linux bits are loaded before extracting as the extractor is
a Linux binary.
Diffstat (limited to 'java')
-rw-r--r--java/linux-jdk13/Makefile12
-rw-r--r--java/linux-sun-jdk13/Makefile12
2 files changed, 24 insertions, 0 deletions
diff --git a/java/linux-jdk13/Makefile b/java/linux-jdk13/Makefile
index b2b3381511be..d8bdec195cf2 100644
--- a/java/linux-jdk13/Makefile
+++ b/java/linux-jdk13/Makefile
@@ -49,6 +49,18 @@ IGNORE= You must manually fetch the Java 2 Development Kit ${PORTVERSION} \
then run make again
.endif
+pre-extract:
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading Linux kernel module...' | fmt; \
+ linux || { \
+ ${ECHO} 'The Linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
+ ${FALSE}; \
+ };\
+ fi
+
post-fetch:
@${CHMOD} +x ${DISTDIR}/${DISTFILES}
diff --git a/java/linux-sun-jdk13/Makefile b/java/linux-sun-jdk13/Makefile
index b2b3381511be..d8bdec195cf2 100644
--- a/java/linux-sun-jdk13/Makefile
+++ b/java/linux-sun-jdk13/Makefile
@@ -49,6 +49,18 @@ IGNORE= You must manually fetch the Java 2 Development Kit ${PORTVERSION} \
then run make again
.endif
+pre-extract:
+ @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
+ ${ECHO} 'Linux mode is not enabled.\
+ Loading Linux kernel module...' | fmt; \
+ linux || { \
+ ${ECHO} 'The Linux kernel module could not be loaded.\
+ Please manually load the module and retry.\
+ See "man linux" for details.' | fmt; \
+ ${FALSE}; \
+ };\
+ fi
+
post-fetch:
@${CHMOD} +x ${DISTDIR}/${DISTFILES}