aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-10-28 03:52:27 +0800
committerpav <pav@FreeBSD.org>2007-10-28 03:52:27 +0800
commit0dad1135ff809570b244a035e219ef054786bc50 (patch)
tree101b16ace55aaf7c001452b4b8963407f2dc0d6f /java
parentb9f5a399436e426ee11a5821946bb4c30a33f8df (diff)
downloadfreebsd-ports-gnome-0dad1135ff809570b244a035e219ef054786bc50.tar.gz
freebsd-ports-gnome-0dad1135ff809570b244a035e219ef054786bc50.tar.zst
freebsd-ports-gnome-0dad1135ff809570b244a035e219ef054786bc50.zip
- Only support emacs22 (cedet only does that as far as I can see)
Reported by: pointyhat
Diffstat (limited to 'java')
-rw-r--r--java/jde/Makefile17
1 files changed, 3 insertions, 14 deletions
diff --git a/java/jde/Makefile b/java/jde/Makefile
index 307b4f69b1f2..1ed165a19531 100644
--- a/java/jde/Makefile
+++ b/java/jde/Makefile
@@ -16,23 +16,12 @@ MAINTAINER= dougk@dougk-ff7.net
COMMENT= Java Development Environment for Emacs
USE_EMACS= yes
-EMACS_PORT_NAME?= emacs21
+EMACS_PORT_NAME?= emacs22
.include <bsd.port.pre.mk>
-.if ${EMACS_PORT_NAME} == "emacs22"
-CEDETPORTSUFFIX=${PKGNAMESUFFIX}
-ELIBPORTSUFFIX=
-.elif ${EMACS_PORT_NAME} == "emacs21"
-CEDETPORTSUFFIX=
-ELIBPORTSUFFIX= ${PKGNAMESUFFIX}
-.else
-CEDETPORTSUFFIX=${PKGNAMESUFFIX}
-ELIBPORTSUFFIX= ${PKGNAMESUFFIX}
-.endif
-
-BUILD_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/cedet/common/cedet.el:${PORTSDIR}/devel/cedet${CEDETPORTSUFFIX} \
- ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/elib/avltree.el:${PORTSDIR}/devel/elib${ELIBPORTSUFFIX}
+BUILD_DEPENDS= ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/cedet/common/cedet.el:${PORTSDIR}/devel/cedet \
+ ${LOCALBASE}/${EMACS_VERSION_SITE_LISPDIR}/elib/avltree.el:${PORTSDIR}/devel/elib
RUN_DEPENDS= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}