aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2017-04-14 06:45:40 +0800
committerbsam <bsam@FreeBSD.org>2017-04-14 06:45:40 +0800
commit34515b3bd057924ba5c9283156f7dfdc89c0b6f2 (patch)
tree5afe61b751a261c6597e38b0b59d1b4645a0edbd /java
parent9bc5a6385972b01568b5dbba0d1e401255794f58 (diff)
downloadfreebsd-ports-gnome-34515b3bd057924ba5c9283156f7dfdc89c0b6f2.tar.gz
freebsd-ports-gnome-34515b3bd057924ba5c9283156f7dfdc89c0b6f2.tar.zst
freebsd-ports-gnome-34515b3bd057924ba5c9283156f7dfdc89c0b6f2.zip
java/intellij: Update to version 2017.1.1, use no-jdk distfile.
Diffstat (limited to 'java')
-rw-r--r--java/intellij/Makefile21
-rw-r--r--java/intellij/distinfo6
-rw-r--r--java/intellij/pkg-plist3
3 files changed, 15 insertions, 15 deletions
diff --git a/java/intellij/Makefile b/java/intellij/Makefile
index a7dd05ed4a21..a78314e2811c 100644
--- a/java/intellij/Makefile
+++ b/java/intellij/Makefile
@@ -5,11 +5,11 @@
# Vadim Zhukov <zhuk@openbsd.org>
PORTNAME= intellij
-PORTVERSION= 2017.1
+PORTVERSION= 2017.1.1
CATEGORIES= java devel
MASTER_SITES= https://download.jetbrains.com/idea/ \
http://download.jetbrains.com/idea/
-DISTNAME= ideaIC-${PORTVERSION}
+DISTNAME= ideaIC-${PORTVERSION}-no-jdk
MAINTAINER= bsam@FreeBSD.org
COMMENT= IntelliJ IDEA Community Edition
@@ -21,12 +21,14 @@ RUN_DEPENDS= intellij-fsnotifier>0:java/intellij-fsnotifier \
USE_JAVA= yes
JAVA_VERSION= 1.7+
+USES= python:run shebangfix
+SHEBANG_FILES= bin/printenv.py bin/restart.py
NO_ARCH= yes
NO_BUILD= yes
INSTALL_TARGET= install-strip
-WRKDIST= ${WRKDIR}/idea-IC-171.3780.107
+WRKSRC= ${WRKDIR}/idea-IC-171.4073.35
.include "common.mk"
@@ -36,29 +38,26 @@ SUB_LIST+= IDEA_HOME=${IDEA_HOME}
do-install:
${MKDIR} ${STAGEDIR}${IDEA_HOME}
- @${TAR} -czf - -C ${WRKDIST} . | ${TAR} xzf - -C ${STAGEDIR}${IDEA_HOME}
+ @${TAR} -czf - -C ${WRKSRC} . | ${TAR} xzf - -C ${STAGEDIR}${IDEA_HOME}
# Linux/Windows/OS X only so remove them
@${RM} ${STAGEDIR}${IDEA_HOME}/bin/fsnotifier \
${STAGEDIR}${IDEA_HOME}/bin/fsnotifier-arm \
${STAGEDIR}${IDEA_HOME}/bin/fsnotifier64 \
- ${STAGEDIR}${IDEA_HOME}/bin/libbreakgen.so \
- ${STAGEDIR}${IDEA_HOME}/bin/libbreakgen64.so \
${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-linux-*.jar \
${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-osx-*.jar \
- ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-windows-*.jar \
+ ${STAGEDIR}${IDEA_HOME}/plugins/gradle/lib/native-platform-windows-*.jar
# Remove the bundled native Pty4J support libraries, they are replaced
# by java/intellij-pty4j
@${RM} -r ${STAGEDIR}${IDEA_HOME}/lib/libpty
- @${RM} -r ${STAGEDIR}${IDEA_HOME}/jre
${INSTALL_SCRIPT} ${WRKDIR}/idea ${STAGEDIR}${PREFIX}/bin/idea
${INSTALL_MAN} ${FILESDIR}/idea.1 ${STAGEDIR}${PREFIX}/man/man1
${INSTALL_DATA} ${WRKDIR}/idea.desktop ${STAGEDIR}${PREFIX}/share/applications/
- cd ${WRKDIST}/lib && ${JAVA_HOME}/bin/jar xf icons.jar
- ${INSTALL_DATA} ${WRKDIST}/lib/icon.png ${STAGEDIR}${IDEA_HOME}/idea.png
+ cd ${WRKSRC}/lib && ${JAVA_HOME}/bin/jar xf icons.jar
+ ${INSTALL_DATA} ${WRKSRC}/lib/icon.png ${STAGEDIR}${IDEA_HOME}/idea.png
# TODO: Remove and enable fsnotifier when devel/libinotify is fixed
# Disable filewatcher warning message on IDEA startup
${ECHO} "idea.filewatcher.disabled=true" >> ${STAGEDIR}${IDEA_HOME}/bin/idea.properties
# Use fsnotifier replacement provided by java/intellij-fsnotifier
-# ${ECHO} "idea.filewatcher.executable.path=${IDEA_HOME}/bin/fsnotifier" >> ${STAGEDIR}${IDEA_HOME}/bin/idea.properties
+ ${ECHO} "idea.filewatcher.executable.path=${IDEA_HOME}/bin/fsnotifier" >> ${STAGEDIR}${IDEA_HOME}/bin/idea.properties
.include <bsd.port.mk>
diff --git a/java/intellij/distinfo b/java/intellij/distinfo
index c73715c204bb..789874864436 100644
--- a/java/intellij/distinfo
+++ b/java/intellij/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1490625127
-SHA256 (ideaIC-2017.1.tar.gz) = 750b517742157475bb690c1cc8f21ac151a754a38fec5c99a4bb473efd71da5d
-SIZE (ideaIC-2017.1.tar.gz) = 427717734
+TIMESTAMP = 1492106337
+SHA256 (ideaIC-2017.1.1-no-jdk.tar.gz) = 3b7f2b906c2a22b3323aba1f9bd4719147f0534e823d4313265c6bcbf92cda60
+SIZE (ideaIC-2017.1.1-no-jdk.tar.gz) = 354538090
diff --git a/java/intellij/pkg-plist b/java/intellij/pkg-plist
index cd404853d4f6..32ba666bfa33 100644
--- a/java/intellij/pkg-plist
+++ b/java/intellij/pkg-plist
@@ -149,7 +149,7 @@ share/applications/idea.desktop
%%IDEA_HOME%%/lib/miglayout-swing-5.0.jar
%%IDEA_HOME%%/lib/nanoxml-2.2.3.jar
%%IDEA_HOME%%/lib/nekohtml-1.9.14.jar
-%%IDEA_HOME%%/lib/netty-all-4.1.6.Final.Patched.jar
+%%IDEA_HOME%%/lib/netty-all-4.1.9.Final.jar
%%IDEA_HOME%%/lib/openapi.jar
%%IDEA_HOME%%/lib/optimizedFileManager.jar
%%IDEA_HOME%%/lib/oromatcher.jar
@@ -212,6 +212,7 @@ share/applications/idea.desktop
%%IDEA_HOME%%/license/sqljet-license.txt
%%IDEA_HOME%%/license/svnkit-license.txt
%%IDEA_HOME%%/license/swingx_license.txt
+%%IDEA_HOME%%/license/trove4j_license.txt
%%IDEA_HOME%%/license/winp_license.txt
%%IDEA_HOME%%/license/xerces_license.txt
%%IDEA_HOME%%/license/xmlrpc_license.txt