aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2015-05-13 03:03:30 +0800
committermi <mi@FreeBSD.org>2015-05-13 03:03:30 +0800
commit43445bdbcff15d98cc97d01addb2006a1c662fdc (patch)
tree9f48ce664d0bbf8960070c2b4acb0a32e609b58d /java
parent93192fb2d3ebb3fda1649c6aeb735163c3608df6 (diff)
downloadfreebsd-ports-gnome-43445bdbcff15d98cc97d01addb2006a1c662fdc.tar.gz
freebsd-ports-gnome-43445bdbcff15d98cc97d01addb2006a1c662fdc.tar.zst
freebsd-ports-gnome-43445bdbcff15d98cc97d01addb2006a1c662fdc.zip
Fix the build in the case of newer JUnit, that, in its turn, uses hamcrest now.
Upgrade from 6.1.5 to 6.2.31. Based on: PR: 156251 Submitted by: pi Now that the test-target fully works, add "regression-test" alias to it so it can be used for that purpose.
Diffstat (limited to 'java')
-rw-r--r--java/berkeley-db/Makefile6
-rw-r--r--java/berkeley-db/distinfo4
-rw-r--r--java/berkeley-db/files/patch-junit32
-rw-r--r--java/berkeley-db/pkg-descr3
4 files changed, 25 insertions, 20 deletions
diff --git a/java/berkeley-db/Makefile b/java/berkeley-db/Makefile
index b8ab8f08552c..027ca6f3cdbe 100644
--- a/java/berkeley-db/Makefile
+++ b/java/berkeley-db/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= je
-PORTVERSION= 6.1.5
+PORTVERSION= 6.2.31
CATEGORIES= java databases
MASTER_SITES= http://download.oracle.com/berkeley-db/ \
http://download-east.oracle.com/berkeley-db/ \
@@ -20,15 +20,13 @@ JAVA_VERSION= 1.7+
USE_ANT= yes
MAKE_ENV+= JAVALIBDIR="${JAVALIBDIR}"
MAKE_ARGS+= -cp ${JAVALIBDIR}/junit.jar
-USES= dos2unix
-DOS2UNIX_FILES= build.xml
PLIST_FILES= %%JAVAJARDIR%%/je.jar
PORTDOCS= *
PORTEXAMPLES= *
-test:
+regression-test check test:
#
# Running the vendor-provided self-tests. This may take a while
#
diff --git a/java/berkeley-db/distinfo b/java/berkeley-db/distinfo
index b26c2b99b67d..5fc874fa33ac 100644
--- a/java/berkeley-db/distinfo
+++ b/java/berkeley-db/distinfo
@@ -1,2 +1,2 @@
-SHA256 (je-6.1.5.tar.gz) = 778122759dc79080e599410c3540ce2e64e6bcaf26c9b4944639fdfe66d2cc8a
-SIZE (je-6.1.5.tar.gz) = 11171411
+SHA256 (je-6.2.31.tar.gz) = d8854f6385e8369232c9805ef94232c8e9c4800ec0c60ff79a6e60d00036b969
+SIZE (je-6.2.31.tar.gz) = 11198631
diff --git a/java/berkeley-db/files/patch-junit b/java/berkeley-db/files/patch-junit
index 314176172f22..951d95f399eb 100644
--- a/java/berkeley-db/files/patch-junit
+++ b/java/berkeley-db/files/patch-junit
@@ -1,31 +1,39 @@
---- build.xml Wed Sep 20 18:10:10 2006
-+++ build.xml 2014-09-29 14:22:48.000000000 -0400
-@@ -135,6 +135,8 @@
+--- build.xml 2014-12-17 02:30:51 UTC
++++ build.xml 2015-05-12 12:14:56 -0400
+@@ -132,6 +132,9 @@
</path>
+ <property environment="env"/>
<path id="unittest.classpath">
<path refid="class.path"/>
+ <pathelement location="${env.JAVALIBDIR}/junit.jar"/>
++ <pathelement location="${env.JAVALIBDIR}/hamcrest.jar"/>
<pathelement location="${unittest.destdir}"/>
- </path>
-@@ -469,4 +471,5 @@
- <property name="destdir" value="${unittest.testevolvedir}"/>
+ <pathelement path="${junit.jarfile}"/>
+@@ -872,5 +875,5 @@
+ </target>
+
+- <target name="compile-unittest" depends="compile-src, get-junit-jar">
++ <target name="compile-unittest" depends="compile-src">
+ <ant antfile="ant/compile.xml" dir="." inheritall="false">
+ <property name="srcdir" value="${unittest.srcdir}"/>
+@@ -917,4 +920,5 @@
+ <property name="destdir" value="${unittest.testserialdir}"/>
<reference refid="class.path" torefid="compile.classpath"/>
+ <reference refid="unittest.classpath" torefid="compile.classpath"/>
</ant>
- </target>
-@@ -1224,5 +1227,4 @@
+
+@@ -2127,5 +2131,4 @@
<mkdir dir="${installdir}"/>
<mkdir dir="${installdir}/docs"/>
- <mkdir dir="${installdir}/bin"/>
<mkdir dir="${installdir}/lib"/>
<copy todir="${installdir}/docs">
-@@ -1233,7 +1235,4 @@
- <copy todir="${installdir}/lib">
+@@ -2137,7 +2140,4 @@
<fileset dir="lib"/>
-- </copy>
+ </copy>
- <copy todir="${installdir}/bin">
- <fileset dir="bin"/>
- </copy>
+- </copy>
</target>
+
diff --git a/java/berkeley-db/pkg-descr b/java/berkeley-db/pkg-descr
index 1c2e96327bff..b10d5cdaf87c 100644
--- a/java/berkeley-db/pkg-descr
+++ b/java/berkeley-db/pkg-descr
@@ -1,6 +1,5 @@
This is a pure-Java implementation of Berkeley DB by SleepyCat (now
-Oracle). Java-1.5 is required for building, although the result should
-be usable with 1.4 too. From the
+Oracle). Java-1.7 is required for building. From the
WWW: http://www.oracle.com/technetwork/database/berkeleydb/