aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorznerd <znerd@FreeBSD.org>2002-02-22 02:31:18 +0800
committerznerd <znerd@FreeBSD.org>2002-02-22 02:31:18 +0800
commitab5590c94521c1f4cc544926899b5ea35178d0ab (patch)
tree065046f1038716e5ddda2b3d78c755b25892c9b0 /java
parent11dd4901ee99c19b1e213f88b53cbd78a939a2a1 (diff)
downloadfreebsd-ports-gnome-ab5590c94521c1f4cc544926899b5ea35178d0ab.tar.gz
freebsd-ports-gnome-ab5590c94521c1f4cc544926899b5ea35178d0ab.tar.zst
freebsd-ports-gnome-ab5590c94521c1f4cc544926899b5ea35178d0ab.zip
Now uses USE_LINUX instead of an obscure RUN_DEPENDS.
Reported by: David W. Chapman Jr. <dwcjr@inethouston.net>
Diffstat (limited to 'java')
-rw-r--r--java/linux-blackdown-jdk12/Makefile3
-rw-r--r--java/linux-jdk/Makefile3
2 files changed, 4 insertions, 2 deletions
diff --git a/java/linux-blackdown-jdk12/Makefile b/java/linux-blackdown-jdk12/Makefile
index 9e5041980d7a..58b164afabbf 100644
--- a/java/linux-blackdown-jdk12/Makefile
+++ b/java/linux-blackdown-jdk12/Makefile
@@ -23,11 +23,12 @@ RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base \
NO_CDROM= "License doesn\'t allow distribution with fee"
NO_PACKAGE= "License doesn\'t allow binary distributions"
+USE_LINUX= YES
ONLY_FOR_ARCHS= i386
USE_BZIP2= YES
WRKSRC= ${WRKDIR}/jdk1.2.2
-NO_BUILD= yes
+NO_BUILD= YES
do-install:
${MKDIR} ${PREFIX}/linux-jdk1.2.2
diff --git a/java/linux-jdk/Makefile b/java/linux-jdk/Makefile
index 9e5041980d7a..58b164afabbf 100644
--- a/java/linux-jdk/Makefile
+++ b/java/linux-jdk/Makefile
@@ -23,11 +23,12 @@ RUN_DEPENDS= /compat/linux/lib/ld.so:${PORTSDIR}/emulators/linux_base \
NO_CDROM= "License doesn\'t allow distribution with fee"
NO_PACKAGE= "License doesn\'t allow binary distributions"
+USE_LINUX= YES
ONLY_FOR_ARCHS= i386
USE_BZIP2= YES
WRKSRC= ${WRKDIR}/jdk1.2.2
-NO_BUILD= yes
+NO_BUILD= YES
do-install:
${MKDIR} ${PREFIX}/linux-jdk1.2.2