aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2012-06-13 04:00:27 +0800
committermi <mi@FreeBSD.org>2012-06-13 04:00:27 +0800
commitc112320f25f2dd794442abc68b2b5bf72d021819 (patch)
tree7580eaddb8665c3f25ccaf75a1e5e54084202446 /java
parent0bac18bdce284ff525b8ff3578fa0e3bb681f3bb (diff)
downloadfreebsd-ports-gnome-c112320f25f2dd794442abc68b2b5bf72d021819.tar.gz
freebsd-ports-gnome-c112320f25f2dd794442abc68b2b5bf72d021819.tar.zst
freebsd-ports-gnome-c112320f25f2dd794442abc68b2b5bf72d021819.zip
Either linimon@ in 2011 or hq@ in 2006 broke the wrapper-script -- the
%%JAVA_VERSION%% inserted into it was never expanded... Now that we aren't using JDK-1.{3,4} anyway, the setting of JAVA_VERSION is, probably, redundant. Remove it and bump PORTREVISION. While here, declare the port as unsafe for parallel building. Unfortunately.
Diffstat (limited to 'java')
-rw-r--r--java/jode/Makefile3
-rw-r--r--java/jode/files/patch-bin-jode5
2 files changed, 4 insertions, 4 deletions
diff --git a/java/jode/Makefile b/java/jode/Makefile
index 27c764e57661..dec89cc0fbac 100644
--- a/java/jode/Makefile
+++ b/java/jode/Makefile
@@ -6,7 +6,7 @@
PORTNAME= jode
PORTVERSION= 1.1.1.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/1.1.2-pre1
DISTNAME= ${PORTNAME}-${VENDOR_VERSION}
@@ -23,6 +23,7 @@ JAVA_VERSION= 1.5+
NEED_JAVAC= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
+MAKE_JOBS_UNSAFE= yes
GETOPT_JAR= ${JAVALIBDIR}/getopt.jar
CLASSLIB= ${JAVA_CLASSES}:${GETOPT_JAR}
diff --git a/java/jode/files/patch-bin-jode b/java/jode/files/patch-bin-jode
index a5e07eca4f32..4f5f689cf777 100644
--- a/java/jode/files/patch-bin-jode
+++ b/java/jode/files/patch-bin-jode
@@ -5,7 +5,7 @@
-prefix=@prefix@
case $1 in
-@@ -9,6 +8,7 @@
+@@ -9,6 +8,6 @@
esac
+# This will only set CP if CLASSPATH is non-empty:
@@ -14,5 +14,4 @@
-CP=`echo $CLASSPATH | sed s/:/,/`
-CLASSPATH=@datadir@/jode-@VERSION@.jar:@CLASSPATH@ \
-@JAVA@ $CLAZZ --classpath $CP $*
-+JAVA_VERSION="%%JAVA_VERSION%%" exec @prefix@/bin/java -cp @datadir@/jode-@VERSION@.jar:@datadir@/getopt.jar \
-+ $CLAZZ $CP "$@"
++exec @prefix@/bin/java -cp @datadir@/jode-@VERSION@.jar:@datadir@/getopt.jar $CLAZZ $CP "$@"