aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorphantom <phantom@FreeBSD.org>2003-03-13 19:15:24 +0800
committerphantom <phantom@FreeBSD.org>2003-03-13 19:15:24 +0800
commit0c92ef6c599654b85735f883ff36ab550255df93 (patch)
tree8551c02c23be0cd144b372f06cd7ba05ecf917a5 /java
parent586168388f0113b7d99b91284deee2d6c763a29c (diff)
downloadfreebsd-ports-gnome-0c92ef6c599654b85735f883ff36ab550255df93.tar.gz
freebsd-ports-gnome-0c92ef6c599654b85735f883ff36ab550255df93.tar.zst
freebsd-ports-gnome-0c92ef6c599654b85735f883ff36ab550255df93.zip
Make sure that demo/jfc/SwingSet2/resources does not exists (it should not,
but sometimes leaves in)
Diffstat (limited to 'java')
-rw-r--r--java/jdk14/Makefile2
-rw-r--r--java/jdk15/Makefile2
-rw-r--r--java/jdk16/Makefile2
3 files changed, 6 insertions, 0 deletions
diff --git a/java/jdk14/Makefile b/java/jdk14/Makefile
index 9ac795aa45fc..5a2931c02994 100644
--- a/java/jdk14/Makefile
+++ b/java/jdk14/Makefile
@@ -141,6 +141,8 @@ do-build:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
post-build:
+ @# XXX make sure that SwingSet2/resources does not exists
+ @${RM} -rf ${JDKIMAGEDIR}/demo/jfc/SwingSet2/resources
@# This file serves no purpose (in case of port)
@${RM} -f ${JDKIMAGEDIR}/src.zip
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index 9ac795aa45fc..5a2931c02994 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -141,6 +141,8 @@ do-build:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
post-build:
+ @# XXX make sure that SwingSet2/resources does not exists
+ @${RM} -rf ${JDKIMAGEDIR}/demo/jfc/SwingSet2/resources
@# This file serves no purpose (in case of port)
@${RM} -f ${JDKIMAGEDIR}/src.zip
diff --git a/java/jdk16/Makefile b/java/jdk16/Makefile
index 9ac795aa45fc..5a2931c02994 100644
--- a/java/jdk16/Makefile
+++ b/java/jdk16/Makefile
@@ -141,6 +141,8 @@ do-build:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
post-build:
+ @# XXX make sure that SwingSet2/resources does not exists
+ @${RM} -rf ${JDKIMAGEDIR}/demo/jfc/SwingSet2/resources
@# This file serves no purpose (in case of port)
@${RM} -f ${JDKIMAGEDIR}/src.zip