aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /java
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'java')
-rw-r--r--java/classpath/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 6648eb2aba06..93e63f07fe46 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -115,7 +115,8 @@ CONFIGURE_ARGS+= --enable-qt-peer
CONFIGURE_ARGS+= --enable-default-toolkit=gnu.java.awt.peer.qt.QtToolkit
.endif
CONFIGURE_ENV+= MOC="${LOCALBASE}/bin/moc-qt4"
-USE_QT4= moc_build corelib gui
+USES+= qt:4
+USE_QT= moc_build corelib gui
PLIST_SUB+= QT4=""
.else
PLIST_SUB+= QT4="@comment "