aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2008-08-29 13:27:16 +0800
committerglewis <glewis@FreeBSD.org>2008-08-29 13:27:16 +0800
commitfa05b92151a8a1b376cbbedc19cab2078e3052ee (patch)
tree5df93766a87994063740473e95b6ddf79d7d2af3 /java
parent61f6467e28750b847977d33208c5a3492b380bc6 (diff)
downloadfreebsd-ports-gnome-fa05b92151a8a1b376cbbedc19cab2078e3052ee.tar.gz
freebsd-ports-gnome-fa05b92151a8a1b376cbbedc19cab2078e3052ee.tar.zst
freebsd-ports-gnome-fa05b92151a8a1b376cbbedc19cab2078e3052ee.zip
. Enforce JAVA_VERSION of 1.6 on FreeBSD 7.x and better. While jdk15 will
work, diablo-jdk15 won't, so the safest way to do this is to just enforce jdk16 or diablo-jdk16. . Enforce using something that was compiled on FreeBSD 8.x since the binary packages are likely to cause problems.
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index f7400294d0e8..89633d194385 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -61,6 +61,10 @@ MAKE_CAIRO= make_cairo
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700000
+JAVA_VERSION= 1.6
+.endif
+
+.if ${OSVERSION} >= 800000
JAVA_VENDOR= bsdjava
.endif