aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2013-03-27 11:11:33 +0800
committerglewis <glewis@FreeBSD.org>2013-03-27 11:11:33 +0800
commit06709a67c5a893ce2c030036cd40c0d734181f1b (patch)
treea2064e56074bb9fee5aa250ba04b259148e93055 /java
parentcc85b82089372f8ad3e5f4e2f4de1e1b42992a12 (diff)
downloadfreebsd-ports-gnome-06709a67c5a893ce2c030036cd40c0d734181f1b.tar.gz
freebsd-ports-gnome-06709a67c5a893ce2c030036cd40c0d734181f1b.tar.zst
freebsd-ports-gnome-06709a67c5a893ce2c030036cd40c0d734181f1b.zip
. Fix the location of the
FILES_c += initIDs.c line so it comes after FILE_c is explicitly set in the BSD specific block. This fixes missing symbols in libawt. Submitted by: Kurt Miller (kurt@intricatesoftware.com) Obtained from: http://hg.openjdk.java.net/bsd-port/bsd-port/jdk/rev/ef510cd4aec5
Diffstat (limited to 'java')
-rw-r--r--java/openjdk7/files/patch-zzz-make-sun-awt-Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/java/openjdk7/files/patch-zzz-make-sun-awt-Makefile b/java/openjdk7/files/patch-zzz-make-sun-awt-Makefile
new file mode 100644
index 000000000000..c13f54679579
--- /dev/null
+++ b/java/openjdk7/files/patch-zzz-make-sun-awt-Makefile
@@ -0,0 +1,20 @@
+--- jdk/make/sun/awt/Makefile.orig 2013-03-26 18:41:21.000000000 -0700
++++ jdk/make/sun/awt/Makefile 2013-03-26 18:41:38.000000000 -0700
+@@ -123,8 +123,6 @@
+ OTHER_LDLIBS = $(JVMLIB) $(LIBM) $(LIBDL)
+ endif
+
+-FILES_c += initIDs.c
+-
+ ifeq ($(PLATFORM), bsd)
+ FILES_c = $(FILES_2D_c)
+ FILES_c += awt_LoadLibrary.c
+@@ -139,6 +137,8 @@
+ OTHER_LDLIBS = $(JVMLIB) $(LIBM)
+ endif
+
++FILES_c += initIDs.c
++
+ # ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ SOLARIS/LINUX
+ endif # PLATFORM
+