aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-02-21 08:58:30 +0800
committerhq <hq@FreeBSD.org>2005-02-21 08:58:30 +0800
commit6b701f1eb85906487376822861df58bb03931a8b (patch)
tree437edfcc06955c32bc195b7d827a0f9aff70f110 /java
parent3169441959b6126ca103d403895010522804cf3e (diff)
downloadfreebsd-ports-gnome-6b701f1eb85906487376822861df58bb03931a8b.tar.gz
freebsd-ports-gnome-6b701f1eb85906487376822861df58bb03931a8b.tar.zst
freebsd-ports-gnome-6b701f1eb85906487376822861df58bb03931a8b.zip
- Update to version 2005.02.17
- Add WITH_EXTRAS knob to include source code examples - Improve pkg-descr PR: 77796 Submitted by: maintainer
Diffstat (limited to 'java')
-rw-r--r--java/java-tutorial/Makefile34
-rw-r--r--java/java-tutorial/distinfo14
-rw-r--r--java/java-tutorial/pkg-descr9
3 files changed, 50 insertions, 7 deletions
diff --git a/java/java-tutorial/Makefile b/java/java-tutorial/Makefile
index 20e1fdf72ccc..4cbbbfbc34f4 100644
--- a/java/java-tutorial/Makefile
+++ b/java/java-tutorial/Makefile
@@ -5,14 +5,16 @@
# $FreeBSD$
#
-# Install size for version 2004.03.11 is ~22827 kB.
-
PORTNAME= jdk-tutorial
-PORTVERSION= 2004.03.11
-PORTREVISION= 1
+PORTVERSION= 2005.02.17
CATEGORIES= java
-MASTER_SITES= http://java.sun.com/docs/books/tutorial/download/
+MASTER_SITES= http://java.sun.com/docs/books/tutorialNB/download/
+.if defined(WITH_EXTRAS)
+DISTNAME= tutorial.zip tut-examples.zip tut-swing.zip tut-bookstore-21.zip \
+ tut-bookstore-tomcat.zip tut-bingo
+.else
DISTNAME= tutorial
+.endif
MAINTAINER= ringworm01@gmail.com
COMMENT= Official Java 2 SDK tutorial
@@ -35,4 +37,26 @@ do-install:
@${CHOWN} -h -R ${DOCOWN}:${DOCGRP} ${DOCSDIR}
@${ECHO_MSG} " [ DONE ]"
+post-install:
+ @${ECHO} "***********************************************************************"
+ @${ECHO} "* *"
+.if !defined(WITH_EXTRAS)
+ @${ECHO} "* make install WITH_EXTRAS=1 will add to the installation: *"
+ @${ECHO} "* *"
+ @${ECHO} "* 1) source files for all the tutorial examples *"
+ @${ECHO} "* *"
+ @${ECHO} "* 2) Some examples such as the BINGO and Servlets Bookstore examples *"
+ @${ECHO} "* include many source files in a rather complex directory structure, *"
+ @${ECHO} "* so these examples are separate files. *"
+ @${ECHO} "* *"
+ @${ECHO} "* 3) The JFC/Swing trail *"
+ @${ECHO} "* *"
+.endif
+ @${ECHO} "* Set your browser to ${DOCSDIR}/index.html and enjoy! *"
+ @${ECHO} "* *"
+ @${ECHO} "* Michael C. Shultz (port maintainer) *"
+ @${ECHO} "* ringworm01@gmail.com *"
+ @${ECHO} "* *"
+ @${ECHO} "***********************************************************************"
+
.include <bsd.port.post.mk>
diff --git a/java/java-tutorial/distinfo b/java/java-tutorial/distinfo
index 958da60a95d9..692686e1a35e 100644
--- a/java/java-tutorial/distinfo
+++ b/java/java-tutorial/distinfo
@@ -1,2 +1,12 @@
-MD5 (tutorial.zip) = 5b48a3679d6871e65856dc17cdae61c6
-SIZE (tutorial.zip) = 14199235
+MD5 (tutorial.zip) = 0a27eb4244e6a40f6572239813fcec66
+SIZE (tutorial.zip) = 14689562
+MD5 (tut-examples.zip) = 88917388e41ef50cb4e064a3d0c46adf
+SIZE (tut-examples.zip) = 5953512
+MD5 (tut-swing.zip) = fe3a2dbc1442106631b944df37804e8b
+SIZE (tut-swing.zip) = 7433266
+MD5 (tut-bookstore-21.zip) = cfd834d8a03dde7e34860f62f05e5f89
+SIZE (tut-bookstore-21.zip) = 18252
+MD5 (tut-bookstore-tomcat.zip) = bdc9413498ccb7104192b0db3820619f
+SIZE (tut-bookstore-tomcat.zip) = 31353
+MD5 (tut-bingo.zip) = 2ef5f5d39e462fa1da01b17d30e362bf
+SIZE (tut-bingo.zip) = 38158
diff --git a/java/java-tutorial/pkg-descr b/java/java-tutorial/pkg-descr
index 6580137e0f14..0d5d103242cd 100644
--- a/java/java-tutorial/pkg-descr
+++ b/java/java-tutorial/pkg-descr
@@ -1,4 +1,13 @@
+The Java(tm) Tutorial
+
+A practical guide for programmers with hundreds of complete, working
+examples and dozens of trails--groups of lessons on a particular
+subject.
+
Tutorial for Sun's Java Developers Kit (JDK). For more information about
the JDK for FreeBSD see http://www.freebsd.org/java/
WWW: http://www.freebsd.org/java/
+
+Michael C. Shultz (port maintainer)
+ringworm01@gmail.com