aboutsummaryrefslogtreecommitdiffstats
path: root/java
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2012-11-01 06:07:56 +0800
committerglewis <glewis@FreeBSD.org>2012-11-01 06:07:56 +0800
commita6b4857d7e07ff12c92f8e2eeadf144f15898299 (patch)
tree370eea21ec92a4f458cc2cbc12fcd1c751530c30 /java
parent750a1997ccaae73c527e1dce204147d9cdbdd165 (diff)
downloadfreebsd-ports-gnome-a6b4857d7e07ff12c92f8e2eeadf144f15898299.tar.gz
freebsd-ports-gnome-a6b4857d7e07ff12c92f8e2eeadf144f15898299.tar.zst
freebsd-ports-gnome-a6b4857d7e07ff12c92f8e2eeadf144f15898299.zip
. Introduce a DEBUG option and default it to unset. For now the .debuginfo
files are only installed if the option is set. In future it will likely also mean to enable the debug and/or fastdebug build. PR: 172627 Feature safe: yes
Diffstat (limited to 'java')
-rw-r--r--java/openjdk7/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index 598cf9894496..a4fa3118cb1f 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${PORT_MINOR_VERSION}.${PORT_BUILD_NUMBER}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk${JDK_MAJOR_VERSION}u${JDK_MINOR_VERSION}/promoted/b${JDK_BUILD_NUMBER}/ \
http://download.java.net/jaxp/1.4.5/:jaxp \
@@ -34,8 +35,9 @@ USE_ICONV= yes
USE_XORG+= x11 xext xi xrender xt xtst
MAKE_JOBS_UNSAFE= yes
-OPTIONS_DEFINE= POLICY TZUPDATE
+OPTIONS_DEFINE= DEBUG POLICY TZUPDATE
OPTIONS_DEFAULT= POLICY TZUPDATE
+DEBUG_DESC= Enable extra debugging info
POLICY_DESC= Install the Unlimited Strength Policy Files
TZUPDATE_DESC= Update the time zone data
@@ -111,6 +113,10 @@ BOOTSTRAP_JDKS= ${LOCALBASE}/openjdk7 \
.include <bsd.port.options.mk>
+.if empty(PORT_OPTIONS:MDEBUG)
+MAKE_ENV+= ALT_OBJCOPY="/nonexistent"
+.endif
+
.if ${PORT_OPTIONS:MTZUPDATE}
RUN_DEPENDS+= ${LOCALBASE}/share/java/zi:${PORTSDIR}/java/java-zoneinfo
.endif